Sign in to follow this  
Followers 0
mrmaxx

Strange Dell Latitude issue

10 posts in this topic

The laptop is a Dell Latitude D531. It works fine wirelessly if it's docked or not. It does NOT work wired if it's undocked. The current user is a local admin on the machine. Even if I log him out and log in as myself it doesn't work and I'm a domain admin.

If you go into the network properties and try to enable the NIC, it says "Windows is unable to enable this device" and just goes away.

Any ideas? I'm kinda baffled on this one.

----EDIT----

I have narrowed this down to a software issue. I'm going to as the mods to move this to the "software" section. thanks!

Edited by mrmaxx

Share this post


Link to post
Share on other sites

Coming in a bit late, maybe you've already got it sorted ... but, the first jump to me (making the assumption that Windows is involved) would be the 'computer/hardware profile' .... the 'undocked' mode disabling the hardware ethernet interface, or possibly simply not recognizing it at all in that mode.

Moved the Topic, as per your request.

Share this post


Link to post
Share on other sites
Coming in a bit late, maybe you've already got it sorted ... but, the first jump to me (making the assumption that Windows is involved) would be the 'computer/hardware profile' .... the 'undocked' mode disabling the hardware ethernet interface, or possibly simply not recognizing it at all in that mode.

Thanks. Yeah... somehow the "undocked" profile seems to be disabling the NIC. I'm going to try to delete that hardware profile and see if it recreates it (I hope.)

Share this post


Link to post
Share on other sites
The laptop is a Dell Latitude D531. It works fine wirelessly if it's docked or not. It does NOT work wired if it's undocked. The current user is a local admin on the machine.

<snip>

...Interesting, I have almost the reverse problem -- my notebook (Dell D620, Windows XP SP2) can connect to the internet with a cable but attempts at wireless connection only work when I am at home (where I'm usually docked; it's been over a year since I tried to connect while undocked at home but I think it worked; I've tried my wireless at several places away from home and all have failed). I looked at the hardware profiles hardware resource mappings and they appear okay. Any ideas?

Share this post


Link to post
Share on other sites

Another possibility... some Dell's have a power saving BIOS setting to turn off the NIC when running on battery.

Since I am often using my laptop to test network ports, I disable this feature.

Share this post


Link to post
Share on other sites
<snip>

some Dell's have a power saving BIOS setting to turn off the NIC when running on battery.

<snip>

...Thanks, Steven. In my case, I was running on AC even when not docked.

Share this post


Link to post
Share on other sites
...Interesting, I have almost the reverse problem -- my notebook (Dell D620, Windows XP SP2) can connect to the internet with a cable but attempts at wireless connection only work when I am at home (where I'm usually docked; it's been over a year since I tried to connect while undocked at home but I think it worked; I've tried my wireless at several places away from home and all have failed). I looked at the hardware profiles hardware resource mappings and they appear okay. Any ideas?

What types of connections have you tried in the "away" mode| For example, I seem to recall having issues with WEP when trying to use the pass phrase, but worked fine when I used the hex string.

What firewall might you be using, thinking of a setting for "trusted" networks being involved??? For example, I've been forced to notice that some of the defaul settings are different between manufacturers (and even different model numbers from the same vendor) some using 192.168.0.x, other using 192.168.1.x.

Share this post


Link to post
Share on other sites
What types of connections have you tried in the "away" mode| For example, I seem to recall having issues with WEP when trying to use the pass phrase, but worked fine when I used the hex string.

What firewall might you be using, thinking of a setting for "trusted" networks being involved??? For example, I've ben forced to notice that some of the defaul settings are different between manufactures (and even different model numbers from the same vendor) some usiong 192.168.0.x, other using 192.168.1.x.

...It has failed with both trusted and secured (WPA2-PSK) networks. On the secured network, it worked fine when I plugged directly into the router. Via wireless on the secured network, I tried disabling my personal firewall, Symantec Endpoint Protection, before connecting, to no avail.

Share this post


Link to post
Share on other sites
Thanks. Yeah... somehow the "undocked" profile seems to be disabling the NIC. I'm going to try to delete that hardware profile and see if it recreates it (I hope.)

Coming back VERY late to the discussion... that indeed did solve the problem. Not sure how the profile got FUBARed, but deleting the profile and letting it auto-create fixed it just fine.

Share this post


Link to post
Share on other sites

...Finally, a (at least for one remote location) resolution! I had occasion to visit the hospital where I could not connect back in September 2010, this time with both my work notebook PC and with the Android my wife carries (she was having an outpatient procedure). Again, no luck with the notebook. But the Android worked and -- I had forgotten that many portals have this feature -- up popped an (paraphrasing) "I accept the AUI" page! I found the URL for that page, typed it into my work notebook PC and, voila, I was in business! :) <g> Am now looking forward to visiting other locations to see if the same routine works.

...Any thoughts on the best way to "force" the "Accept AUI" page to come up in my browser if I don't have the the URL handy? I can't imagine it's as simple as a browser "Refresh" -- I surely must have tried that!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0