Jump to content
Sign in to follow this  
szuliani

All Incoming Mail Blocked

Recommended Posts

I just found out today that all incoming email is being blocked by SpamCop, no matter the sending domain. In order to receive email again, I had to disabled SpamCop in our Exchange IP Block LIst Providers list. Fortunately, we have a second provider in the list that is functioning properly. I also checked SpamCop's blocklist for several of the sending mail servers and found that none of them were on the list. I also checked on SpamHAUS' block list and got the sam results. So, my question is, does anyone know how I can find out why this is happening and how to get it corrected?

Share this post


Link to post
Share on other sites

&nbspĀ &nbsp&nbsp&nbsp&nbspĀ Not that I can answer your question but just to check understanding: you are saying that your Exchange server was blocking e-mail because you had configured it to reject e-mails coming from IP addresses on the SCBl but that it was causing rejection of e-mails coming from IP addresses that are not on the SCBl? Not that I'm an expert on how the SCBl works but my understanding was that that isn't possible (although I don't doubt you -- my understanding of either what you did or how using the SCBl works is flawed). I would like to point out that SC recommends not using the SCBl to reject spam but, rather, to filter/ sort it and deliver it to a location other than users' inboxes so that it can be evaluated for "false positives" as you seemed to have experienced. When you "checked SpamCop's blocklist for several of the sending mail servers and found that none of them were on the list," did you check the copy of the SCBl that your Exchange server was using to reject or did you use some other mechanism? I ask because it is possible that the copy your Exchange server was using was out-of-date or somehow corrupted.

Share this post


Link to post
Share on other sites

We had configured the Exchange server "IP Block LIst Providers" option to use SpamHAUS and SpamCop as the providers. The server had been functioning perfectly for quite a while with these settings, until yesterday that is. For an unknown reason, virutally all email was no longer being received and we started getting calls from the intended recipents stating that they were getting rejection notification emails. Through trial and error, I found that disabling SpamCop as a provider in Exchange permitted email to be delivered to the recipients again. After this, I configured a custom rejection notice to tell me the iP address of the sending mail server and the source that was reporting it as being on a block list. This morning we started getting calls from clients stating that they were getting rejection notifications again with SpamHAUS as the reporting provider.

Short story long, I found that it was an issue with Exchange and had to disable the "IP Block LIst Providers" option all together. We are not looking into alternate options such as an appliance or a third party paid service.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×