Jump to content
Sign in to follow this  
fragpup

Is it just me that can't sign in to the e-mail sys

Recommended Posts

It's not working at my end neither. I was going nuts for a while wondering how to get out of this since I couldn't find any Contact Email at Spamcop Net.

What can we do if we expect very important emails?

There may be a lesson to be learned here.

Spamnet is great but, in situations such as this one, we are stuck without any control.

Thanks!

Share this post


Link to post
Share on other sites

I have confirmed this problem. An Admin has been paged. Please try https://webmail.spamcop.net (it works for me). Thanks!

Share this post


Link to post
Share on other sites

I will be restarting my browser shortly to test.

Share this post


Link to post
Share on other sites
It's now working. Problem seems to have been resolved.

Thank you!

I agree.

Share this post


Link to post
Share on other sites

Your help is very appreciated. In my case, this has been a learning experience.

When experiencing difficulties with our account, where should we go for help/instructions? Here? Are there contact emails somewhere? Thanks!

Share this post


Link to post
Share on other sites
I have confirmed this problem.  An Admin has been paged.  Please try https://webmail.spamcop.net (it works for me).  Thanks!

Sorry, my mistake, I had two browser sessions open to Webmail with HTTPS at the time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×