Jump to content
gnarlymarley

Cannot find ip range in whois output

Recommended Posts

The IPv6 ranges returned from the lacnic whois is being properly detected.  It appears that most of the whois servers return inet6num, but lacnic seems to be returning inetnum.  For documentation, the IPv4 seems to be coming back as NetRange for all whois.  It would appear that lacnic is going to stay with this as they have used this since they started on IPv6.  Can we have the code in the whois section be able to pick up lacnic's IPv6 range?

The tracking URL that was fixed by the deputies on 24 Feb but have screenshot of before fix: https://www.spamcop.net/sc?id=z6618132220z787713e4d45691f5d7d62752a3a7f109z

blob.png.f5b66b94572cd9eba88f25aa229912e6.png

Forum post from 2013: http://forum.spamcop.net/topic/13290-gmail-spam-from-ipv6/

Forum post from 2018: http://forum.spamcop.net/topic/30227-cannot-find-ip-range-in-whois-outputno-reporting-addresses-found-for-200112f0601a902000150/

Whois refresh page:

blob.thumb.png.225acba8c6446b37dfa82e2029af702d.png

Share this post


Link to post
Share on other sites
On 4/4/2020 at 7:51 AM, gnarlymarley said:

most of the whois servers return inet6num, but lacnic seems to be returning inetnum

one possible option would be to do a regex swap when the whois is pulled into the cache such as:

s/inetnum/inet6num/

 

Share this post


Link to post
Share on other sites

Or in perl speak:

$whoisoutput =~ s/inetnum/inet6num/ if $whoisoutput =~ m/inetnum:.*?::/;

The if is so IPv4 is ignored.  Would be better to have full IPv6 address detection in place of the "::".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×