Jump to content
EkriirkE

Linsk are not parsed when Return-Path is empty

Recommended Posts

Occasionally I will get an email where the body is not parsed/ignored and I got another today that I did some poking around, and I found that if the Return-Path  header exists and is empty (`Return-Path: <>`), the body is ignored.   Removing or populating it resolve the issue.

Share this post


Link to post
Share on other sites
2 hours ago, EkriirkE said:

Occasionally I will get an email where the body is not parsed/ignored and I got another today that I did some poking around, and I found that if the Return-Path  header exists and is empty (`Return-Path: <>`), the body is ignored.   Removing or populating it resolve the issue.

BEFORE you submit a spam at top of page there is a tracking URL  copy this track and past it here, then one can see what is happening.

example
Here is your TRACKING URL - it may be saved for future reference:
https://www.spamcop.net/sc?id=z6690533908ze72fd31a4dff786edaf29eccae16c308z

Share this post


Link to post
Share on other sites
20 minutes ago, petzl said:

BEFORE you submit a spam at top of page there is a tracking URL  copy this track and past it here, then one can see what is happening.

example
Here is your TRACKING URL - it may be saved for future reference:
https://www.spamcop.net/sc?id=z6690533908ze72fd31a4dff786edaf29eccae16c308z

What are you going on about?  You can't get a tracking link for a spam you haven't submitted yet.  That's a catch 22.  And I'm not trying to report spamcop report links

Share this post


Link to post
Share on other sites
1 hour ago, EkriirkE said:

What are you going on about?  You can't get a tracking link for a spam you haven't submitted yet.  That's a catch 22.  And I'm not trying to report spamcop report links

Unless headers are shown safest way is by a Tracking URL
,Without one or headers have no idea what you are on about either?
If you paste headers replace your email address with a x

Share this post


Link to post
Share on other sites

I forward as attachments, been doing so for over a decade.  This is a bug which only affects about 1 spam a year.  I doubt my methods of simply clicking the forward button are randomly "mis pasting" an email of thousands consistently

Share this post


Link to post
Share on other sites
On 11/30/2020 at 2:12 PM, EkriirkE said:

Occasionally I will get an email where the body is not parsed/ignored and I got another today that I did some poking around, and I found that if the Return-Path  header exists and is empty (`Return-Path: <>`), the body is ignored.   Removing or populating it resolve the issue.

I have seen this a while ago, but I didn't have time to do any research on it.  I will have to pay attention for the next time I get a spam that has links, but they get ignored.  (I think mine were August or July, so they are probably past the 90 days so I will not be able to get tracking URLs.)

Share this post


Link to post
Share on other sites
2 hours ago, gnarlymarley said:

I have seen this a while ago, but I didn't have time to do any research on it.  I will have to pay attention for the next time I get a spam that has links, but they get ignored.  (I think mine were August or July, so they are probably past the 90 days so I will not be able to get tracking URLs.)

This is a failed parse https://www.spamcop.net/sc?id=z6693341449z0778223c9998b219a4bda561ffbc4addz 

this version parsed  https://www.spamcop.net/sc?id=z6693545149z7a985f0f94faa3a5d9a2fa784fd2555bz

 

The only difference is I removed the Return-Path header

Share this post


Link to post
Share on other sites
1 hour ago, EkriirkE said:

This is a failed parse https://www.spamcop.net/sc?id=z6693341449z0778223c9998b219a4bda561ffbc4addz 

this version parsed  https://www.spamcop.net/sc?id=z6693545149z7a985f0f94faa3a5d9a2fa784fd2555bz

The only difference is I removed the Return-Path header

194.150.215.174 (Bounce)
so SpamCop does not lookup links
Possibly your email addy is on the reply address

Share this post


Link to post
Share on other sites
1 hour ago, petzl said:

194.150.215.174 (Bounce)
so SpamCop does not lookup links
Possibly your email addy is on the reply address

No.  Read the posts.

Share this post


Link to post
Share on other sites
On 11/30/2020 at 4:42 PM, EkriirkE said:

Here is your TRACKING URL - it may be saved for future reference:
https://www.spamcop.net/sc?id=z6690533908ze72fd31a4dff786edaf29eccae16c308z

I think this may have caused some confusion as the above tracking URL is missing the body.  See below for verification test.

On 12/1/2020 at 5:09 PM, EkriirkE said:

So I took your link that failed to parse and I added something in the return-path.  The links would parse again.  So I submitted it as is and it fails to parse.  Clearly, it appears you have caught a problem or bug here where SpamCop is broken.

Working (changed return-path): https://www.spamcop.net/sc?id=z6693978467z3560f51112de7e9fcadc539b521ce73bz

Not working: https://www.spamcop.net/sc?id=z6693978389zca5cee5269c5f353471c599d70e7c266z

As you can see by comparing, I submitted the same thing twice, except I added an email in the return path.

Share this post


Link to post
Share on other sites

I've put this in our developers' queue to have a look at.  The key is here:

Reports regarding this spam have already been sent:
Re: 194.150.215.174 (Bounce)
Reportid: 7097982956 To: noc@galaxydata.ru
 
The spam with the blank RP is treated as a bounce by the system
 
Richard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×