Jump to content
Sign in to follow this  
Wazoo

System went nasty

Recommended Posts

I am sorry to bother you with my computer woes, but I need some confirmation - since I am not at all confident on what the problem is and don't really know anyone here that I trust to give me good advice.

And to make sure you get good advice, I'm putting this "out there" so that even what I say can be challenged by someone with a better idea <g>

For a while, OE, Mozilla seem to take forever to start up. I put it down to McAfee doing its thing. Also, lately I have had to open Mozilla when I am offline or there is a pop up that wants me to do a survey about Netscape which crashes Mozilla. No viruses lately or anything else strange.

Item 1 - the anti-vius checking thing. First guess is that your anto-virus tool is set to "check files when they are run/opened" ... For some people, this is a good thing, example: those that click on those attachment to see what they are/do ... If you are the type that handles things in a more secure fashion (example: save that attachment somewhere else, do your virus scan on that saved file, then maybe take a look at it) .. you don't download and run all kinds of files found in strange places on the net, etc., this is one of those things that just gets in the way. In fact, when installing new software, the warning that pops up about making sure nothing else is running is primarily based on anti-virus tools running with the "check when file is run/opened mode" .. the interference caused by all the scanning/checking usually tends to muck up the installation.

The Mozilla pop-up .. don't use that application, but ... one of the first things when talking about a pop-up ... java scri_pt is usually involved, which has little touches all over the place .. for exampe, what restrictions might you have on running java scri_pt/activeX things under Windows? There are settings under FireFox, so I'd assume they were available under Mozilla also as to restrictions/allowances on running these things ... both javascrpt and pop-ups ... (more later)

Then, Sunday, before I even opened internet programs, I tried entering something in Access and it crashed. The scan disk thing got hung up when the computer restarted. So I went to safemode and did a thorough scandisk, then defrag, but when I started up this morning half the short cut icons on the desktop are just the place icons (though they still work).

Assumption on a 'recent' version of Offic/Access involved ... that's a pretty hefty application .. a crash there would not be considered out the ordinary, unfortunately .. way to many things to pick out a possibility from this limited data ... (however, more later)

Icons issue: Windows has a default "space" set aside to handle icons. If you load up your desktop with shortcuts, have your system tray full of applications, the Quick-start section all loaded up, there is the likelyhood that this space has been exceeded .... and/or the (hidden system) file C:/Windows/ShellIconCache has been scrambled. One thing to try to bring them back ... Start | Settings | Control Panel | Display | Appearance .... select "icon" in one drop-down menu ... you'll typically see the size setting at (I'll say) 32 .. change that number, Apply ... change it back to what it was, Apply again .... see if this forced refresh of this file brought the icons back.

If this doesn't work, then try renaming (or deleting) that file and re-boot ... which will cause a new one to be built fresh. (windows default install won't let you 'see' this file, however Start | Find | Files and Folders should bring it up in that window where you can then "do something" with it)

To simplify this in the future, Microsoft has (had?) an app TWEAKUI that has a repair function built in that basically does this automaticly without having to re-boot ... this tool isn't "supported" ... but I use it <g>

If the issue is too many icons, I can post a hack to the Registry that increases the "space" alloted to hold more icons ....

I looked at the stats: Windows has 195,872 KB of memory (which seems low to me). With Mozilla up, I have 59% system resources. Disk space when I look at Windows Explorer says 25.6 GB available.

Suggesting that your computer (probably) has 256Meg or RAM installed. Depending on how you actually use that computer, a lot of folks live with that on a Win-98 machine. Again, depending o how you use it, throwing more memory in may either nock your socks off at the improvement or you may not notice a thing (well, disk thrashing would be reduced for sure) ....

Anything to make the customer (feel) happy. Back in the days of Win 3.x ... things like that displaye RAM and Resources were based on the maximum amout of Memory installed ... of course, by the time Windows loaded, all the Office stuff (in default mode) and any other software that used the "preload during boot so that when the user clicks on the icon, it starts up 'really' fast" .. the displayed numbers were really, really low ... That was "fixed" in later versios of Windows, such the 100% number was calculated on the amount of memory left over "after" Windows loaded ... so what used to be 15% available now displayed as 78%, because of the difference in the "baseline" that the number was calculated from ... oe still had exactly the same amount of "free" resources, but people weren't bitching any more <g>

25+Gig of hard drive space could be good for most. It might be a problem for others. Once again, back to how you use that computer, what software is involved, etc. For example, I'm still using ancient software that would refuse to work with that much space thrown at them. The problem is that these humongous hard drives also carry wit them equally humongous sector/cluster sizes, and the old software can't understand those huge numbers coming back, so immediately assumes that the hard drive is totally hosed. I have a number of 2.1Gig partitions set up for those applications.

There are still some issues with how many files are stored in a "root" folder/partition ... One may have all inds of drive space available, but there's only so much room set aside to hold file names and pointers to where they are actually stored on the hard drive. In theory, Win-98 can handle that issue, but we're back to the applications themselves again .... Usual hint there is to star creating sub-directories/folders as those don't have the same file-name limits ....

We have a new version of QuickBooks (Home and Office version) that has had problems from the get go with open windows (it won't minimize or sometimes if minimized, won't restore).

My gut feeling is that between QuickBooks and Mcaffee - which are both designed for XP and I still have Win98 - that they are screwing up something. And possibly using up all my memory.

There's "designed for" .. "designed with xxx in mind" ... designed to be compatible with" ... and probably some more .... if the package you bought said Compatible with Win-XP and that's it, be amazed that it loaded and runs at all .... If it said Compatible wirh XP, 98SE, 98, xxx then technically it should recognize which OS you're running and not install (in ths case) the XP specific code .... 98 and XP are a whole lot different at the core .. 98 stuff will generally run under XP (some configuration issues, a compatibility mode may need to be set, if it makes some direct-to-hardware calls all bets are off) .. but XP specific stuff will not erun under 98, end of story.

I haven't tried Access again, but Word opened and didn't crash.

However, when I sent an email this morning, the hard drive got really busy for a long time - I am not very observant so I don't know if that was unusual or not or if it was McAfee or Zone Alarm doing something.

There was much talk about the latest release(s) of ZoneAlarm, also going the "one tool that does everything" route and managing to do the same as McAfee, Symantec, etc al ... just sticking too many fingers in too many places and causing problems in all kinds of off the wall places. So once again, we may be back to the version of the applications involved and some of the configuration settings. For example, I use AVG which offers that "check and certify as virus free all outgoing e-mail" ... As I only send out plain-text e-mail, no attachments, there is no reason to have that process running. (systems are checked regularly with an AVG scan from one system, NOD from another, an on-line scan every now and then, etc. etc. .. no need to get into all my security things right now ..) Just going to if you've got these applications set to do this outgoing scanning ...

I am thinking about buying another computer (with USB ports) and networking it with the old one and putting the QuickBooks and the internet stuff on the new one and continue to use the old one for MS Office and, I guess, storage (so I don't have to decide what to delete. It looks to me as though it has plenty of room on the hard disk.)

So, that's where I am. Am I on the right track? Or should I be looking for something else wrong?

First of all, I'm hoping that the USB ports aren't directly connected to the "networking" part ... though there are USB networking things out there, I'm tired of having to "fix" them .... USB wasn't meant for that, I don't care what the advertising says.

Most definitely get a router (don't have to wait until you get the new computer ... well, if you're still using dial-up, things get a bit funky ..) This will add to your security, make a lot of things easier (once you get over the hurdle of getting the 98 machine to talk to the XP machine anyway)

Now for the "later" part ... the 'typical' thing that might pull all of your crashing, icon, window sizing, etc. stuff together is your video card & video driver. It s possible that installing the newer software also included replacig/updating of some files that aren't quite compatible with either your video hardware, video card drivers and or settings/configuration. And trust me, this is where things get "fun" ....

For starters .. go get, install, and run Belarc Advisor ... this will (attempt) to give you a list of your hardware, your software, version numbers of drivers, etc .... Look at that data, then go on the wild search to see how much of that stuff is "way too old" and look at updating some of it ...

Now the next step for the folks that I directly is that about now is when they usually decide to talk about how their computer is going to end up in my hands <g> After that exercise, their system will have a copy of VNC installed, such that the next time an issue comes up, they can run that app, pass me the specifics on connection details, and I can "look" at their system from here.

Here's hoping something in here gets you to a good place <g>

Share this post


Link to post
Share on other sites

I forgot one major thing that I did before Access crashed. I downloaded some 'critical updates' for Win98 - one of them was for Directx which I didn't recognize as something I use. However, the slowness and the Mozilla crash were before that.

I have never done anything to Mozilla (which I think is the same as Firefox) - no changing any defaults or adding plugins and it does not allow popups. I don't understand why I am getting the Netscape survey pop up anyway (though I do still have a very old version of Netscape installed).

And some of the slowness is due to McAfee - I had to wait until it finished its 'update' download just now because the mouse was slow responding.

I do have email attachments scan checked, but I don't have the outgoing scan checked. And it is not automatic (since I like to report viruses to the IP abuse desk) - which sometimes works and sometimes doesn't. It has been a while since I have gotten any viruses. The Zone Alarm is the free version.

And if I still have Win98, do you think I have a recent version of Office (it's 97)?

I don't think I have too many icons. I would bet the default space is full. I don't care if they don't display as long as it isn't harmful or indicative of something else wrong.

I think my hard drive and my software are compatible because other than the new Quickbooks, have had no problems and neither one are new. The monitor is newer - it is one of those flat screen ones - but I have had that for over a year. I have one at work also. The one at work does it more often than the one at home, but they sometimes don't display without turning on and off several times after 'sleeping' when there is a screen saver. Also one of the problems with Quickbooks - which we fixed by lengthening the screen saver time, was that certain 'go to' buttons were blacked out. The video card could be contributing, but isn't the cause of the current slowness.

I ran Adaware just in case I had picked up something - and it took over 6 hours to complete (I don't know how much longer since I went to bed)- found four cookies. That is much longer than it used to be!!

And the USB ports are to carry files back and forth between computers that I use. The networking is primarily to be able to email Word files. And if I have to get a router, I was thinking about getting DSL. I can also get cable, but the DSL is a local guy and I like to support local. Which is where I would go if I decided to get more memory. They were busy yesterday and of course, want me to bring the computer in to look at usually - which I don't want to do and also they want me to have all the latest - not so much to sell me stuff, but they can't imagine why I wouldn't want all the bells and whistles.

Iwill look at the link. Thanks for the advice. There wasn't anything that was surprising - even if I didn't know what it might be. Then when I go to the local guy, I will know what to ask for. If he is still busy, I might take you up on your offer!

Miss Betsy

Share this post


Link to post
Share on other sites

The icons are back. I had deleted two or three so maybe, even though I don't have a lot there were too many.

Access worked fine. So did a Merge with Word until I tried to print. Error message:

GDI.exe [at] 0001.0000293e

However, after rebooting, I closed the merge file before trying to print a saved document and it worked. (the information in Access and Word were saved even though they crashed).

Miss Betsy

Share this post


Link to post
Share on other sites

Office 97 is not terribly old as far as basic functionality, but it is terribly old as far as security. Have you done Office Update, and Windows Update or Microsoft Update for that matter? Note that Microsoft Update does not cover Office 97, and IME doesn't cover Office 2000 well.

Have you scanned with the latest CWShredder and SpyBot Search&Destroy, and protected yourself with SpywareBlaster?

Have you given the automatically-starting components of Quicktime, RealPlayer, Adobe Reader, and their ilk the old heave-ho?

Have you documented and researched using the latest HiJackThis?

Unless you need anything from your old Netscape, Mozilla, Firefox, and/or Thunderbird (such as bookmarks or email), I suggest scrapping them and installing the latest Mozilla Firefox v1.0.7, and Mozilla Thunderbird (if necessary for email).

Much of the above is documented in my Suggested Free Security Tools and Apps for Windows.

Good luck!

Share this post


Link to post
Share on other sites

Quick note, as I see there's a lot I need to catch up on ..

Office 97 is one of those old applications ... my problem started with Excel spreadsheets, but this is one of those apps moved to one of those 2.1Gig partitions ... But also be advised that if you ever want to re-install it, this also dates back to the times where Microsoft was looking out for it's users and this software will replace a number of files to ensure that you do have the latest versions installed (circa the days of Office 97 ... which of course predates Win-98 by a few days <g> ... there are number of things that need to be "fixed" after the re-install process ...)

I didn't bring up the monitors themselves, though they can have their own issues ... I was going for either circuit card that's plugged into the motherboard .. or possible built right into the circuitry on the motherboard in the computer "box" ..

The GDI.exe error .. I've not found a nice list of error numbers/message for that one, but the causes once again are all over the place, CPU is overgeated, you overclocked your system into warp zone, you deleted the Fonts folder, .. however you said you tried to print ... there's a few references to a GDI error if "the default printer" is not the same printer as the one actually hooked up to the computer ....

GDI.EXE = Windows Graphic Device Interchange Core cmponent .... even the title suggests that it has it's fingers almost everywhere, what with Windows being a "graphical" interface <g> .... so even there, we could once again be talking about the video card & drivers ....

Directx is used all over the place .... not sure I would put the blame on that directly yet, though ..

FireFox is just a web browser .... Mozilla is the "whole" package ...

Zone Alarm - free version .. sure ... but what was talked about was version 5, 6,7 (of course follwed by a bunch of build numbers ...)

Dang it .. this was going to be quick ... but the local cops were quicker, usually not rolling through until about 1015 .... the ticket I just pulled off the windshield (when noticing the time 1009 on screen) was written at 1003 ... off to clean up the coffee grounds on the floor from the knocked over coffe machine that I fired up around 0910 .... oh yeah, it's going to be a fine day <g>

will be back later

Share this post


Link to post
Share on other sites

Let me pay your parking ticket, Wazoo! It says Mozilla on the icon, but all I use is the browser, Firefox. ZA is a 6, I think. I don't remember being asked to upgrade to a 7.

MSOffice doesn't have permission to access the Internet, JeffG. That was my solution for security. I will make sure that I check out your link. Especially to find out how to keep some programs from automatically starting.

It's not that I am cheap, but everything works (until now) just fine without updating - I just don't need all the bells and whistles - though I am aware from buying copy machines at my work that sooner or later, you have to update. I guess it is just time.

So probably it would be better to update MSOffice as well and just make an appointment to have everything installed on a new computer? I don't think I have the time to 'jury rig' old apps. I was hoping against hope that it would be just a simple 'fix' - like finding out to disable a bunch of start ups.

I have had a busy, but not a Monday day yet today (though what I have done may come back to haunt me!). Yesterday was definitely Monday!

Miss Betsy

Share this post


Link to post
Share on other sites
<snip>

It's not that I am cheap, but everything works (until now) just fine without updating - I just don't need all the bells and whistles - though I am aware from buying copy machines at my work that sooner or later, you have to update.  I guess it is just time.

<snip>

34876[/snapback]

...Actually, the updates are more than just bells & whistles -- there are also stability and security features and fixes. In fact, I daresay, mostly stability and security fixes! :) <g>

Share this post


Link to post
Share on other sites

speaking of updates .... Your office apps ... fire one of them up, do a Help | About

Here's hoping there's an SR-2 following the product name ... it's been ages, but I believe that a lot of folks didn't do either SR-1 or SR-2 due to being on dial-up and looking at the 9Meg and 24Meg downloads ...????

Mozilla / FireFox .. even though you only "use" the browser ... it "all" gets loaded ... when starting Mozilla .. FireFox itself is stand-alone ...

What's running .. do the CTRL-ALT-DEL combination button push (once) ... usually suggested - hold down the CTRL and ALT keys, push the DEL key once .... that will bring up the Task Manager and show you what's running (ignoring those nasty suckers that also make sure that they don't show up this way, but again, you said you were virus free <g>) Some of those items may be obvious as to what they are, some will mean nothing at all .... and of course, Microsoft offers no quick and easy way to copy that list .... (other tools out there for that) ...

Share this post


Link to post
Share on other sites
... What's running .. do the CTRL-ALT-DEL combination button push (once) ... usually suggested - hold down the CTRL and ALT keys, push the DEL key once .... that will bring up the Task Manager and show you what's running (ignoring those nasty suckers that also make sure that they don't show up this way, but again, you said you were virus free <g>)  Some of those items may be obvious as to what they are, some will mean nothing at all .... and of course, Microsoft offers no quick and easy way to copy that list .... (other tools out there for that) ...

34878[/snapback]

I'm still running W98 (and W95 and XP) - some of those (legitimate) running processes are quite obscure (names) - and halting some of them can be "interesting". When I had concerns, I found Googling the name of the process always produced links to other folk's queries to help sites, near the top of the long lists, with explanations and (usually) reassurances. That is, using the experience of countless others who have been through similar traumas. Failing that, you could always bounce the names of "suspects" off me (I'm running Office 97 with no "recent" updates on the W98 machine - which never goes near the internet these days though) should be some degree of commonality but time zone difference means you would need to be patient.

[Oh yes - adding the word virus to the process name in the Google search will focus the hits nicely. As said, results usually reassuring - and certainly useful]

Edited by Farelf

Share this post


Link to post
Share on other sites

My MSOffice is SR 2 so I must have updated them sometime. And I just updated from MS Update. And shortly thereafter is when things started happening besides slow downs.

I haven't done a complete virus scan, but haven't really seen any virus like emails. I don't usually surf very much and McAfee told me that they were protecting me from viruses that come without opening anything. That's about the time things slowed down.

I was hoping that if I bought an up to date computer and networked it with my old computer, I could still use my old stuff - which could be emailed sometimes to other people. But it is beginning to look like I am just going to have to upgrade everything.

Like my car - I was driving a truck and so does my husband so we had no car which sometimes it would be nice to have. Then the truck developed a problem with the shifting so I had to start out in 2nd all the time. But it took months before we could go car shopping. I did test drive one car, but it took me so long to return it that the dealer was not happy (just because I never could get there when he was open). I will probably still be rebooting to print something for months to come (or maybe until my son-in-law comes for Christmas - that's how I got the original computer before new hard drive and more memory).

Well, it is late and things don't look so rosy. Maybe I will be able to get to the local place before it closes!

Miss Betsy

Share this post


Link to post
Share on other sites

RealVNC Never heard from them, so not a spam issue ... a spinoff off AT&T, UK

Do not intall it as a "Service" ... (which would mean it's running from boot time)

When installed, look (closely) for "Run VNC Server" .... a new VBC icon will show-up over by the clock .. right-click, properties ... put in a password, check Remove Desktop Wallpaper, enable Java Viewer, Do Nothing, Poll Foreground Window, Poll Console Windows Only, Auto, Accept Socket Connections .... uncheck all others ... Apply | OK ... then hover your mouse over the VNC icon ... An IP address will pop-up (yours) .... while on-line, pass on the IP address and password and (hopefully) be prepared to say Hello! ...

I usually open up Notepad to pass data back and forth, like if I need you to push a key, do a re-boot, etc. I don't recall adding you onto MSN Messanger or which address you'd be using for that anyway ...

Share this post


Link to post
Share on other sites

Don't quite understand that last post. Are you offering to come look at my computer?

After reading the posts, I think that I just have 'old' stuff and like 'old' cars, it has to be babied along and I just don't have time to learn to do that. Also, I have a lot of junk that I don't have time to sort through. And while I appreciate your offer, you have your hands full with helping other people.

I think what I need to do is buy a new computer with XP and a new Office and load the QuickBooks on it, restore the files I use, and start over (especially before they don't have a conversion for my old files anymore). And a new printer and USB ports - which I think will be useful. Until I can get new stuff, I think I can manage to work around the slowness and crashes.

If I don't have time to get new and I start having insurmountable problems, I might take you up on your offer.

Miss Betsy

PS I really appreciate all the advice and the links from everyone!

Share this post


Link to post
Share on other sites
Don't quite understand that last post.  Are you offering to come look at my computer?

34900[/snapback]

Wazoo appeared to be offering to electronically come look at your computer using a remote control program called RealVNC, that he could only use with your permission. He then went on to explain how to install RealVNC using his suggested options.

Share this post


Link to post
Share on other sites

That's what I thought. He is so busy with other things that I hate to bother him. I really think that I just need to bite the bullet and upgrade. Though I thought I would check on updates on this computer and I didn't see any like the ones I did the other day.

Now I am feeling like Typhoid Mary. the computer at work is rebooting spontaneously!! We are supposed to have 'managed' virus protection so I don't see how it could be a virus (I am running a scan now.) someone else suggested that the reset button was bad.

Miss Betsy

Share this post


Link to post
Share on other sites
We are supposed to have 'managed' virus protection so I don't see how it could be a virus (I am running a scan now.)

34906[/snapback]

Virus protection is always in reaction mode...the virus is created and starts to spread, the first people get infected and alert the AV teams, who diagnose and find fixes, then distribute to the world. Some percentage will already be infected by that time.

Share this post


Link to post
Share on other sites
That's what I thought.  He is so busy with other things that I hate to bother him.

On the other hand, what else does he have to do? <g>

Now I am feeling like Typhoid Mary.  the computer at work is rebooting spontaneously!!  We are supposed to have 'managed' virus protection so I don't see how it could be a virus (I am running a scan now.) someone else suggested that the reset button was bad. 

34906[/snapback]

"rebooting spntaniously" .. shades of MsBlaster .. though 98 wasn't normally impacted ... but that does bring up one of thoe "interesting" bits about even keeping your anti-virus tools updated ... to keep the size of the database down, when new virus definitions get added, some old ones usally get dropped. This doesn't go unnoticed ... it wasn't that long ago (well, yeah, I guess it was, thinking back when all this stuff could fit on a floppy) .. I used to recommend keeping copies of previous versions around to run every now and then ... these days, it's generally simply to not place 100% trust in one product/tool ....

"reset button" ... well, that wouldn't be high on my list ... electrically, the normal fail mode of a pushbutton switch is to open up, based on one of the contacts or plunger breaking ... mechanically, (oher then breakage) the typical scenario there would be dust/dirt/grime build-up that wouldn't let the button fully retract, thus being partially pushed in, such that with enough "shaking" the internal contacts 'could' be close enough to make contact ...

My more likely candidate would be to start with a look at the power supply .. typically the +5Volt part loses regulation, so it drops below +5 volts at times .. "everyhting" uses a part of that +5 Volts ... when this issue gets a bit worse, you normally see boot-up problems also, back to the hard drives are spinning up, the CD/DVD units are spinning up,basically everything sucking power, +5 drops to say +4.3, cpu decides that there's an issue, so tries to self-protect itself (or voltage is low enough the CPU can't think straight and the Reset 'line' (where the Reset button would attach) goes "low" enough that the CPU thinks it 'saw' a Reset 'command' .... On the old AT style, these switches went directly to the power supply/CPU reset line ... ATX changed that a bit to end up driving some relays in the power supply (noting that it never really turns off unless you physically unplug it from the wall)

Not knowing what motherboard or exact vintage, there may or may not be one of those "motherboard monitor" programs out there that would at least display the voltages seen. Otherwise, someone's going to have to open the case and get in there with a meter (technically, some of these voltages can be measuered through the pins on various connectors, but making those measurements carries the risk of 'accidentally' shorting other pins, so ... one of those 'geeky' things ...

Share this post


Link to post
Share on other sites

Everything was brandnew in January! When I lost everything in a major crash.

I did a google and sometimes Roxio is to blame, but then Adobe and Firefox wanted to be updated and the UPS man was waiting, but had to let him go on his way because Firefox wouldn't come up to print the labels because I had to say no to reboot because I had something else that I didn't want to close just yet.

However, it is behaving itself now. It does 'beep' the way it does when the power goes off. And one time it didn't shut all the way down because the Word documents I had open reappeared - along with a recovered one.

Ain't computers wonderful!

Miss Betsy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×