Jump to content
Sign in to follow this  
lcusdtech

Parser: couldn't parse head

Recommended Posts

Parser says:

error: couldn't parse head

Message body parser requires full, accurate copy of message

I know I've copied the full headers, can someone take a look at it, I don't read mime headers very well. :)

Tracking url

My guess is that the spammer intentionally mis-formatted it, but I can't tell.

Share this post


Link to post
Share on other sites
... I know I've copied the full headers, can someone take a look at it, I don't read mime headers very well. :) ... My guess is that the spammer intentionally mis-formatted it, but I can't tell.

41453[/snapback]

Yeah, slightly misconfigured - http://www.spamcop.net/sc?id=z902046763za9...db212cd3592672z shows how it would be if written properly. Makes no difference to your reporting, I would say incompetence (no matter which way you cut it).

Share this post


Link to post
Share on other sites

You're welcome. Could be a "trick", who knows? But in the context of the SC parser it achieves nothing. More likely this particular spam "author" just got it a tad wrong. Important things:

  • there was nothing wrong with your processing of the spam
  • the parsing error occurred after the parser had done its thing

For the record, the difference causing the hiccough is

(fragment)

X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180

This is a multi-part message in MIME format.

------=_NextPart_000_0001_01C64B51.5C52C400

Content-Type: multipart/alternative;

        boundary="----=_NextPart_001_000E_01C64B51.5C52C400"

should be
(same fragment)

X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180

This is a multi-part message in MIME format.

----=_NextPart_000_0001_01C64B51.5C52C400

Content-Type: multipart/alternative;

        boundary="----=_NextPart_001_000E_01C64B51.5C52C400"

(Or maybe that's vice versa ;). Pretty subtle, eh? Edited by Farelf

Share this post


Link to post
Share on other sites
Pretty subtle, eh?

41525[/snapback]

Farelf, I would have pointed out that the difference was in the number of -'s. It took me 3 times looking it over to figure out the difference.

Share this post


Link to post
Share on other sites
... It took me 3 times looking it over to figure out the difference.

41553[/snapback]

Yeah, I guess I should have used quotes instead of code, could have highlighted it then. One learns ... unfortunately one forgets at a similar rate :) Keeps the head from exploding, I guess.

[edit]Previous post amended accordingly[/edit]

Edited by Farelf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×