Jump to content
Sign in to follow this  
jefft

Beta Test New Webmail

Recommended Posts

When I logged into the beta this morning, there was a Held Mail button in the top menu, so it seems that you've added it. However, it didn't work (for either of my acccounts), in that instead of displaying the Held Mail, it brought up a new login screen.

Confirmed the same symptom... and the button looks pressed down all the time (box around it) at least with the Purple Horde setting.

Share this post


Link to post
Share on other sites
When I logged into the beta this morning, there was a Held Mail button in the top menu, so it seems that you've added it. However, it didn't work (for either of my acccounts), in that instead of displaying the Held Mail, it brought up a new login screen.

There's a minor bug with this. But, the main problem is that this probably won't work until the site is live at the webmail.spamcop.net address for a few reasons.

JT

Share this post


Link to post
Share on other sites
...this probably won't work until the site is live at the webmail.spamcop.net address for a few reasons.

OK, that's understandable. Any progress on the color scheme issues?

DT

Share this post


Link to post
Share on other sites
OK, that's understandable. Any progress on the color scheme issues?

Yes, I think I see mostly what's going on. I'll probably just fix the database when we make the cut-over. I need to make sure we don't break the old webmail in the meantime.

JT

Share this post


Link to post
Share on other sites

OK, if you can fix the color scheme issues during the transition, then maybe it's time to make the new version "live"? As for the color scheme fix, I think all you'd need to do is to change everone's setting to "Purple Horde" initially and let them change it to something else if they want after the switch.

DT

Share this post


Link to post
Share on other sites

I like to navigate with the keyboard as much as possible. I note that with the new beta software that alt-m no longer takes me to held mail. Also, alt-g no longer logs one off and I see no other shortcut for this.

I'd also like to see more keyboard shortcuts, such as marking all the messages with a single keyboard shortcut.

Finally, a glossary of available shortcuts would be much appreciated.

-er

Edited by earlerobinson

Share this post


Link to post
Share on other sites

I'd also like to see more keyboard shortcuts, such as marking all the messages with a single keyboard shortcut.

Alt-a selects all messages as described earlier in this thread (while updating the current status on problems seen in the previous beta which fizzled).

It is possible you can find a list of all current shortcuts by going to the Horde IMP web site. That is the application in use for the webmail system. If you research it and summarize, I'm sure we could add it to our FAQ or glossary here.

Share this post


Link to post
Share on other sites
It is possible you can find a list of all current shortcuts by going to the Horde IMP web site.

Not sure I recall seeing anything like that under either the user or Admin FAQ/Wiki ....

If you research it and summarize, I'm sure we could add it to our FAQ or glossary here.

No "Help" screens available that list key-codes?

Share this post


Link to post
Share on other sites

No "Help" screens available that list key-codes?

None that I have ever found, not that I have looked heavily. Don't normally use too much key combinations when reading emails.

Share this post


Link to post
Share on other sites
4. There is no more hotkey for "Report as spam" (formerly Alt+E). This would present a big problem for me.
This would be still the case.
This would be a show-stopper for me. :(

a glossary of available shortcuts would be much appreciated.
You can find one at Webmail Keyboard Shortcut Reference Card, posted by JeffG over a year ago.

No, my email address is not obvious.

Edited by justauser

Share this post


Link to post
Share on other sites

I was hoping that we might get any new versions to remember sign-in information, or at least have that option.

Share this post


Link to post
Share on other sites

This thread seems to have been going on for several weeks, but it's only today a notice appeared when I was logging in? Anyhow...

1. We don't seem to have a "white on white" issue here. Can't remember the name of the theme used, but it's kind of light pink/purple. Looks like in the old version.

2. Request we'd been thinking of making for a while: an option to extend Whitelist and Blacklist to more than the 10 or so addresses currently showing on screen. Useful if & when having to check a/o edit those lists rather than browsing blindly.

3. Blacklist in Beta version does not open. Whitelist does.

4. Request made a year or two ago: add a To header to the Date/From/Subject/Size headers. That's because we have strict control on the addresses registered under our domain. "Non-existent" addresses such as info[at] / webmaster[at] / whatever[at]) are reserved exclusively for the use of spammers B). It would save the time needed to open some of the spams with Subject headers that look like valid mail.

5. Looking forward to the improved speed, as I'll be leaving on a three-week trip on Tuesday, with the possibility of only having slow dial-up connections.

Because of the trip, it would be appreciated if any question to the above were also Cc'ed to tingo[at]tanca.com. Not always easy to find the time to browse a forum when traveling.

I was hoping that we might get any new versions to remember sign-in information, or at least have that option.

Our browser (Mozilla) allows for this. On the other hand, do you really want the browsers at any Internet café to remember you?

Share this post


Link to post
Share on other sites

I just had a look, and from my limited perspective, everything worked great. Better than ever! No display issues.

I don't normally look at the webmail -- I open it and don't look at it much. I set up filtering rules so I wouldn't have to create & coordinate the same filters on my IMAP mail readers. (I use Thunderbird because it runs everywhere else, but I'm not wedded to it.) So I was completely satisfied that my filters run just great on the new version.

ALL THAT SAID, I really like the newer version of Horde IMP. I've used it elsewhere, and it's very nice. This one does seem noticeably snappier than other places, so (as discussed earlier) it may not be as fast when everyone else is on it. But I do really like it as a webmail application.

Are there any thoughts of providing any of the other apps in the Horde suite (such as Kronolith)? The Horde suite's import & export & interop features are comparable to desktop PIMs. If spamcop ever added them I might start using Horde more and Thunderbird less.

Just dreamin'....

Share this post


Link to post
Share on other sites
Alt-a selects all messages as described earlier in this thread (while updating the current status on problems seen in the previous beta which fizzled).

It is possible you can find a list of all current shortcuts by going to the Horde IMP web site. That is the application in use for the webmail system. If you research it and summarize, I'm sure we could add it to our FAQ or glossary here.

Nothing is worse than changing hotkeys that are already well established. The new version as done away with alt-g to logoff. Now one must click with the mouse. Similarly, alt-m no longer moves to the held folder. One can do alt-l, h, CR, more keystrokes. Why? The alt-b, to return to the folder in which one was is gone, too. An alt-i will work to return to the inbox but that doesn't help for the held folder, which now requires 3 key strokes rather a single one. Finally, alt-e launched the erasure of the messages in trash and that shortcut has disappeared, too. Oh yes, the older way of checking all messages has been changed for no good reason at all.

-er

Share this post


Link to post
Share on other sites

It's nice to see some other participants weighing in on this topic (it's all due to a new link on the webmail login page, inviting such participation). I don't use the hotkeys, so I'll stay out of that for now, but back to the issues with the color schemes....

My wife's account has had its color scheme changed to "Blue and White." We didn't do that, but I had identified our logins to JT, so maybe he changed it? Or made a more global change? But my account (which previously had "Purple Horde" selected, then that selection got deleted somehow) is still exhibiting the "white on white" problem (specifically in the message composition screen), and when I check my Options, none of the schemes are selected. Yes, I know I could fix the problem myself by selecting one of the schemes, but this is indicative of potential problems for other users, which is the point of testing out a Beta in the first place.

I can also confirm that the "Blacklist" won't open up in the Beta...it produces an entirely blank HTML page without navigation.

DT

Share this post


Link to post
Share on other sites

I did a search and did not find this item in a post:

When selecting "report spam," a new instance of the browser opens (I'm using Safari) whereas in the old scheme the browser simply changed to the reporting URL using the same window.

If it is possible, I would suggest the compromise that the reporting page open in a new tab. IE is supposed to support in it's next incarnation, most browsers already support tabs.

To me, it's a bit inconvenient for a new window to open since it's not clear what happens when selecting "webmail" from this new window. Presently, of course, I am returned to the non-beta version of the webmail page, but I can see a problem with creating too many instances if each selection results in opening a new window.

Share this post


Link to post
Share on other sites
Reply from JT indicated he is looking for more feedback on this before doing a cutover.

Here are a couple more things to look at:

1 - The "Held Mail" button is requiring me to login again

2 - The is no "Empty Trash" button

JLeduc - Big Fan of Spamcop :D

Share this post


Link to post
Share on other sites
I was hoping that we might get any new versions to remember sign-in information, or at least have that option.

Response from JT on same request:

The system is set up to use cookies in the spamcop.net domain but the

server is in the cesmail.net domain. So, all cookies fail and the auth

information is in the URL. I think that will work better once the server

is in the right domain.

Also, if you look up in this thread, you will see a link to an earlier beta and at that time, IE saved teh login information.

Share this post


Link to post
Share on other sites
Reply from JT indicated he is looking for more feedback on this before doing a cutover.

In regards to my previous post - the item regarding itme 2 - the "Empty Trash" button missing,

it is not missing from all accounts.

My own account is OK but my wife's account is missing the icon !

How can that be ??

JLeduc

Share this post


Link to post
Share on other sites
Nothing is worse than changing hotkeys that are already well established. The new version as done away with alt-g to logoff. Now one must click with the mouse. Similarly, alt-m no longer moves to the held folder. One can do alt-l, h, CR, more keystrokes. Why? The alt-b, to return to the folder in which one was is gone, too. An alt-i will work to return to the inbox but that doesn't help for the held folder, which now requires 3 key strokes rather a single one. Finally, alt-e launched the erasure of the messages in trash and that shortcut has disappeared, too. Oh yes, the older way of checking all messages has been changed for no good reason at all.

These are decisions made by the Horde IMP people, actually a long time ago. SpamCop is only implementing the upgrade from the current applicaton. This is actually the second attempt at an application upgrade.

I can also confirm that the "Blacklist" won't open up in the Beta...it produces an entirely blank HTML page without navigation.

This might be a recent problem because I would swear I tested that when I started the Beta.

Here are a couple more things to look at:

1 - The "Held Mail" button is requiring me to login again

2 - The is no "Empty Trash" button

1. Explained earlier in this thread.

2. I have an Empty Trash button. I also have an Empty Trash link inside the Trash folder.

Share this post


Link to post
Share on other sites
When selecting "report spam," a new instance of the browser opens (I'm using Safari) whereas in the old scheme the browser simply changed to the reporting URL using the same window.

If it is possible, I would suggest the compromise that the reporting page open in a new tab. IE is supposed to support in it's next incarnation, most browsers already support tabs.

"Support" is one thing .. "configured to use" is another ....

To me, it's a bit inconvenient for a new window to open since it's not clear what happens when selecting "webmail" from this new window. Presently, of course, I am returned to the non-beta version of the webmail page, but I can see a problem with creating too many instances if each selection results in opening a new window.

I have not looked at the code involved with the Horde/IMP tool, only extrapolating from other web-page layout/design issues .. for example, this Forum application ... I ended up offering two sets of links to the items at the top of the screen to offer that choice .... one link will attempt to open a 'new' browser instance" .. depending on your browser/configuration, this may end up being a new tab or it may be a whole new instance .... the other set will simply 'redirect the browser to a new page' .. and that is even based on exactly how you click it, for example, holding down the Shift key while clicking on it under IE will "open a new browser instance" ....

Share this post


Link to post
Share on other sites
In regards to my previous post - the item regarding itme 2 - the "Empty Trash" button missing,

it is not missing from all accounts.

My own account is OK but my wife's account is missing the icon !

How can that be ??

Options, Deleting and Moving Messages

Only option I see is: Display the "Empty Trash" link in the menubar? which would not be exactly what you are talking about.

Share this post


Link to post
Share on other sites

When I first opened the beta webmail I noticed an inconsistency between which folder is displayed and which folder is identified in the box next to the "Open Folder" button. The folder displayed indicates "Held Mail", while the folder identified in the box next to the "Open Folder" button is "Inbox". In fact the contents displayed were that of "Inbox". It is easy to fix by merely forcing a selection through the use of the "Open Folder" button, but for the sake of minimizing confusion I thought I'd mention that the inital conditions can be a bit inconsistent.

Edited by motobojo

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×