Jump to content
Sign in to follow this  
Krzysio

[Resolved] Can't submit spam reports after switching to Mailhots

Recommended Posts

Hello All,

I've two mailservers with some virtual domains. I've some aliases on both servers which are pointing to my main, IMAP, account on the first one.

I registered my main account, then all my aliases, and even my .Mac acconut in Mailhosts (registration went w/o any problems/warnings etc.), and then... I can't submit any spam to the "Report spam" form anymore. :(

(I'm using mostly Thunderbird (and sometimes Apple Mail) MUA's - both have an options to display message full source correctly)

Now, each time I'm trying to submit a spam, I'm getting result as in these examples:

- spam sent to my main account:

http://www.spamcop.net/sc?id=z1153440534z4...dd1734670bc63ez

- spam sent to one of the aliases on my second mailserver:

http://www.spamcop.net/sc?id=z1153455066z9...97b6b0ee990404z

I have to use Mailhosts, because I don't want my second mailserver to be treaten as spam relay.

Both mailserver are running qmail (the main one also with: vpopmail, simscan, clamd, dspam). Both are using normail, static IP addresses.

What I have to do now?

I searched this forum for a solution for my problem, but I can't find any workingt solution (except of unregistering all of my e-mails from Mailhosts, which unfortunately isn't an option...).

Bestest,

-Chris

Share this post


Link to post
Share on other sites

First Tracking URL;

Received: from unknown (HELO 18913111240.user.veloxzone.com.br) (189.13.111.240)
  by 0 with SMTP; 3 Dec 2006 04:59:45 +0100

Non-MailHosted Tracking URL: http://www.spamcop.net/sc?id=z1153548558zb...d98c58412f3f55z

Second Tracking URL;

Received: from unknown (HELO dns.teleinformatica.com.pl) (195.116.2.6)
  by 0 with SMTP; 3 Dec 2006 12:10:32 +0100

Non-MailHosted Tracking URL: http://www.spamcop.net/sc?id=z1153550999z8...1426735326a843z

The "by 0" condition has been documented before .... the rest of your sample headers don't clearly show any actual handoffs ... a lot of 'invoked' lines, but no actual handoffs ..... bottom line, there is no way for the parser to successfully run through its 'chain test' .... the flow from one server to the next, looking for the injection point/source ....

Share this post


Link to post
Share on other sites

First Tracking URL;

[...]

bottom line, there is no way for the parser to successfully run through its 'chain test' .... the flow from one server to the next, looking for the injection point/source ....

Hmm... it sounds, like registering (in proper order) all of my adresses/aliases in Mailhosts makes more troubles than using the "old" system. :(

If my adresses are not registered in Mailhosts, all is working good (i.e. this one):

<http://www.spamcop.net/mcgi?action=gettrack&reportid=2045330362>

... or ...

<http://www.spamcop.net/mcgi?action=gettrack&reportid=2045241710>

... or ...

<http://www.spamcop.net/sc?track=http%3A%2F%2Fswizxxs.com%2F>

... and my standard headers are accepted w/o a question by SpamCop's engine (and they're correctly interpreted - I checked the technical report).

I'll check the "by 0" in other topics.

Bestest,

-Chris

Share this post


Link to post
Share on other sites

I'll check the "by 0" in other topics.

ERRATA ;)

I found a temporary solution for "by 0" created by qmail-smtpd:

<http://forum.qmailrocks.org/showthread.php?t=3466&goto=nextnewest>

... but it isn't working well for IP based virtual domains (there's no simple way, to place fqdn's of another virtual interfaces here - actually it will place the name of first interface here).

It could be fixed by setting the main IP/hostname as a MX for all domains, but it is rather unpractical (i.e. for users with their own SSL certs), so I have to find another solution...

-C.

Share this post


Link to post
Share on other sites

First Tracking URL;

The "by 0" condition has been documented before ....

And finally, I've got the solution!

It is *very* simple...

I removed the "-l" (dash ell) option from my tcpserver invocation in /service/qmail-smtpd/run'.

Now, tcpserver returns the proper fqdn of used virtual interface!

And... Mailhost registration is no longer a problem - spam submiting is working "from start", even w/o re-registering of my e-mail adresses/aliases.

The puzzle is solved... eh...

Very big thanks for pointing out the "by 0" problem!

Bestest,

-Chris

Share this post


Link to post
Share on other sites

Hi, Chris!

...Thanks for taking the time to return here with the good news! I see someone else has already flagged this thread as "Resolved," based on your feedback.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×