Jump to content
Sign in to follow this  
dnear1

Domain Name mismatch?

Recommended Posts

Frequently for the last week or so, I keep getting this message when trying to POP my messages from Spamcop via Thunderbird:

"You have attempted to establish a connection with "Pop.spamcop.net". However, the security certificate presented belongs to "endeavour.worldmail.org". It is possible, though unlikely, that someone may be trying to intercept your communication with this web site."

Is this something I should definitely cancel/block when I see? Or is it a benign message?

I have been canceling when I get this message. Occasionally, it appears to get the correct certificate and go thru without any errors.

Share this post


Link to post
Share on other sites
Frequently for the last week or so, I keep getting this message when trying to POP my messages from Spamcop via Thunderbird:

"You have attempted to establish a connection with "Pop.spamcop.net". However, the security certificate presented belongs to "endeavour.worldmail.org". It is possible, though unlikely, that someone may be trying to intercept your communication with this web site."

Well...there is a mail service at "worldmail.org" and their IP is similar to that of "pop.spamcop.net" (but you should be using "mail.spamcop.net" instead), and they're both hosted in the same datacenter. Not sure if there's any further connection. I wouldn't worry about the cert errors, but you can report them to SpamCop Email Service here:

http://mail.spamcop.net/contact.php

DT

Share this post


Link to post
Share on other sites

With my mail settings changed to mail.spamcop.net, I now get the same error message, except it states:

You have attempted to establish a connection with "Mail.spamcop.net", However, the security certificate presented belongs to "Pop.spamcop.net"......

Share this post


Link to post
Share on other sites
From: "Wazoo"

To: "JT"

Subject: possible data-center routing issue??

Date: Tue, 20 Nov 2007 23:03:36 -0600

http://forum.spamcop.net/forums/index.php?showtopic=8959

User states;

when trying to POP my messages from Spamcop via Thunderbird:

"You have attempted to establish a connection with

"Pop.spamcop.net". However, the security certificate presented

belongs to "endeavour.worldmail.org". It is possible, though

unlikely, that someone may be trying to intercept your communication

with this web site."

Question would possibly be about an issue with routing in the

data-center ....

Trace mail.worldmail.org (216.154.195.5) ...

Trace pop.spamcop.net (216.154.195.50) ...

Share this post


Link to post
Share on other sites

The problem has progressed to the point now that I can only access my account via Webmail.

Last night, I started getting errors stating my password was incorrect. That happened a number of times where it either went thru successfully or gave me the password error.

Now it simply says "Could not connect to server mail.spamcop.net; The connection was refused"

Share this post


Link to post
Share on other sites

The problem has progressed to the point now that I can only access my account via Webmail.

Have you raised the issue direct with JT and his colleagues who operate the Email service? Wazoo has referred the matter up but I'd raise it directly as well.

You have the Problem button within Webmail or you can submit the issue at http://mail.spamcop.net/contact.php

Andrew

Share this post


Link to post
Share on other sites
The problem has progressed to the point now that I can only access my account via Webmail.

Last night, I started getting errors stating my password was incorrect. That happened a number of times where it either went thru successfully or gave me the password error.

Now it simply says "Could not connect to server mail.spamcop.net; The connection was refused"

That there is nothing else like this being reported/complained about either here or in the newsgroups suggests that this is not a 'system' problem.

That you go even further to state (well, actually not state) that you have any problems hitting 'webmail' seems to point the finger more directly at your Thunderbird application. You've made one change to the configuration described in this Topic, but have you done anything more to try to troubleshoot the problem?

Share this post


Link to post
Share on other sites

That there is nothing else like this being reported/complained about either here or in the newsgroups suggests that this is not a 'system' problem.

That you go even further to state (well, actually not state) that you have any problems hitting 'webmail' seems to point the finger more directly at your Thunderbird application. You've made one change to the configuration described in this Topic, but have you done anything more to try to troubleshoot the problem?

How can I troubleshoot this problem?

Webmail works fine.

I have rebooted my PC several times, toggled my server settings between mail. and pop.spamcop.net with only the same results I describe above. I only did this at the suggestion of the first response post.

The main residual issue I get is the domain mismatch message. If I click OK to it, my password is rejected (Most likely rightly as somehow it is going to wrong address?) If I click Cancel, I cannot get email.

Once in a while, email gets thru, however it is very inconsistent between any changes I do.

My settings have been unchanged since I reinstalled my system earlier this year. I keep XP Pro fully patched and same with Thunderbird. Antivirus, firewall and router are all working properly. Firefox and IE are unaffected, only my spamcop account is affected. If I manually POP my roadrunner email, it works flawlessly.

I am open to ANY suggestions to fix this annoying issue.

Share this post


Link to post
Share on other sites

OK, I've had a chance to take a closer look at this issue and to do some experimenting...here's what I found:

1. On the official SpamCop Email setup instructions pages, both "mail.spamcop.net" *and* "pop.spamcop.net" are given, just on two different pages. When not using SSL, they are functionally equivalent.

2. No mention seems to be made anywhere of using SSL or TLS (aks STLS) when using a POP client to retrieve mail from SpamCop. The only mentions of SSL involve a secure IMAP connection and in setting up your account to POP mail from another ISP, specifically "AT&T Broadband customers (attbi.com)" (which is out of date). I did find a mention of this issue here in the forums, such as here:

http://forum.spamcop.net/forums/index.php?showtopic=6185

but in that thread Steven Underwood pointed out that he wasn't aware of SpamCop offering SSL for POP connections.

3. I experimented with SSL connections on port 995 to both "mail.spamcop.net" and "pop.spamcop.net" and my Pegasus software didn't complain about either, *but* when I tried it on "mail.spamcop.net" in Thunderbird, I got a cert mismatch error that told me the cert is actually for "pop.spamcop.net" -- so I changed my settings to grab from "pop" and it worked just fine.

So, this seems to be an undocumented feature (unless someone comes along and shows us the documentation I missed) and "pop.spamcop.net" does seem to be the correct name to use for SSL POP sessions...for now. HTTPS connections to either hostname show a cert configured for "mail.spamcop.net," however....it's a bit schizophrenic. :-)

So, as mentioned previously, the OP should go straight to the official support to resolve his specific issue.

DT

I am open to ANY suggestions to fix this annoying issue.

Looks like I was composing my message as you posted yours. Here are your choices:

1. stop using SSL and revert to a normal POP session on port 110 -- most of us have been doing that for years without problems...unless you think that someone is trying to sniff out passwords going to and from the server?

2. Use the contact form...it might take a while to get an answer, but that's really your best option if you want to do what you want to do.

DT

Share this post


Link to post
Share on other sites

I was using SSL only because that's how I remember it setting up by default. and it's worked with those settings for years.

I switched to the non-ssl option and it auto-selected port 110.

now, I get connection refused.

change the server from pop. to mail.spamcop.net and mail comes unhindered.

Share this post


Link to post
Share on other sites
I switched to the non-ssl option and it auto-selected port 110. now, I get connection refused. change the server from pop. to mail.spamcop.net and mail comes unhindered.

I just tested again using Thunderbird and the non-SSL port 110 and didn't have any problems with either "pop" or "mail" so there's either something wrong with your account or with your Thunderbird. We probably can't do anything more for you here....there's no official support here, just other users trying to help, using their own experiences and best guesses to diagnose problems and offer solutions. I think your issue might require the attention of the actual operators of the servers.

DT

Share this post


Link to post
Share on other sites

Do you have a host table setup locally with pop.spamcop.net configured? Both POP and MAIL should resolve to: 216.154.195.50 There is no reason why POP on port 110 should not work for either name unless you are not connecting to the correct IP address.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×