Jump to content

[Resolved] Email whitelisted and blocked by SpamAssassin


Recommended Posts

Hi folks,

I looked around the forum some and didn't find anything exactly like this... I hope it isn't a repeat of something already discussed.

I just noticed this because of the SpamAssassin 20XX problem. I sent this email to my daughter's SpamCop account. I use the SpamCop POP tool to download all of her email (because she is too young to have unmonitored email). So the message entered my SpamCop account via the POP tool. It has my from-address and her to-address. It ended up in the Held Mail folder. This is what the relevant header lines contained:

X-SpamCop-Checked: 11.222.33.44

X-SpamCop-Whitelisted: myusername[at]spamcop.net

X-SpamCop-Checked:

X-SpamCop-Disposition: Blocked SpamAssassin=3

So it looks like the mail system whitelisted it and blocked it anyway.

???

Link to comment
Share on other sites

So the message entered my SpamCop account via the POP tool. It has my from-address and her to-address. It ended up in the Held Mail folder. This is what the relevant header lines contained:

X-SpamCop-Checked: 11.222.33.44

X-SpamCop-Whitelisted: myusername[at]spamcop.net

X-SpamCop-Checked:

X-SpamCop-Disposition: Blocked SpamAssassin=3

So it looks like the mail system whitelisted it and blocked it anyway.

I assume your SA trigger is 3 or less ?

Since the 2010 SA bug is gone it may be some time before you see another such bug

but what I see in the same situation (but delivered to Inbox) is

X-SpamCop-Checked:

X-SpamCop-Disposition: Blocked SpamAssassin=4

X-SpamCop-Whitelisted: [munged].co.uk

Which has the lines in the usual order and no extra "X-SpamCop-Checked: 11.222.33.44 " which should not be present unless the SA=4 wasn't or wasn't recognised.

Suggest you do and cancel a TRACKER and report it to JT by clicking the "problem" button from webmail.

Link to comment
Share on other sites

Yes, my SA setting is 3. Usually works great.

The 11.222.33.44 is an IP address that I munged.

The system obviously did something for this email in a different order than usual... i.e., it did the blocking action after the whitelisting.

I haven't had any more such problems since the 20XX problem was fixed.

I'll follow up if I see any more.

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...