Jump to content

OT: Postfix blocking of spamcop-based reports


forrie
 Share

Recommended Posts

I'm using MUTT as my mail agent, which I have for years, but I'm having a problem with Postfix rejecting the mail based on header_checks (which I need, as I have a spammer). My Spamcop mutt config is based on the documentation:

# Settings for SPAMCOP
set mime_forward=yes
set mime_forward_rest=yes

set ssl_verify_host=no
set ssl_verify_dates=no

macro index S ":set autoedit=no fast_reply=yes  editor=\"/bin/true\"\n<tag-prefix><forward-message>submit.[omitted][at]spam.spamcop.net\n<send-message>:set autoedit=yes fast_re
ply=no editor=\"/usr/bin/vim\"\n" \
        "Forward tagged mail to SpamCop"

But, something isn't working. I fould imagine that if it's mime_forward, the body of the reports should be encoded, but postfix is rejecting based on the headers of the messages I'm sending.

It's possible I've overlooked something, but I understand there was a lengthy discussion somewhere about this (which I cannot find). If someone could point me in the right direction, that would be very much appreciated.

Thank you.

Link to comment
Share on other sites

Without knowing what is sent to SpamCop or the error message it is hard to troubleshoot. If you have a Tracking URL from one of the spam you submit that should provide both.

As for the proper setting within MUTT to implement SpamCop reporting, maybe someone else here knows that app.

Link to comment
Share on other sites

To clarify, I think it has to do with how the message is being encoded. I added a couple of rules to my Postfix header_checks that catch this spammer abusing Google Groups, but it catches the headers in the forwarded message -- which it should not, that I can tell, from the mutt configuration.

The config for mutt above is from the Spamcop FAQ.

Link to comment
Share on other sites

The Postfix header_checks documentation lists settings nested_header_checks & mime_header_checks, which default to be the same as header_checks and are applied "to message headers of attached email messages" and "to MIME related message headers only". If you haven't set those to be different from the main header_checks setting, then it's probably one of them catching the headers of the attached message when you try to forward it to SpamCop. (I wouldn't like to say which one it is without testing it, and I don't have a Postfix server handy for testing right now :-) )

Edited by AJR
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...