Jump to content

Stopping empty (null) msgs


Recommended Posts

Hi,

I just signed up for Spamcop.net and all seems to be working smoothly, except my first batch of messages were empty messages with no subject line. Is there someway to immediately have them deleted or shoved to the held mail area before I see them?

I spent some time looking over this area and the FAQs for this answer, so I apologize in advance if I missed the answer.

Thanks

Link to comment
Share on other sites

Hi,

I just signed up for Spamcop.net and all seems to be working smoothly, except my first batch of messages were empty messages with no subject line.  Is there someway to immediately have them deleted or shoved to the held mail area before I see them?

I spent some time looking over this area and the FAQs for this answer, so I apologize in advance if I missed the answer.

Thanks

21916[/snapback]

Welcome!

If the emails you don't want don't have a from address, you can add a Filter to do this. My Filter that does this is named "No From At" and is described as follows:

From not contain "[at]"

Deliver to mailbox: INBOX.Held Mail

[stop]

Sorry, but there doesn't seem to be a "Doesn't Exist" qualifier, just "Contains" and "Doesn't contain". :(

Link to comment
Share on other sites

Thanks, I'll try it. Now can someone tell me how to see entire threads or simply "go to the next message" on this board? I can't seem to find a switch to do this here. I do see the thread list on the bottom of the window, and can click one msg at a time, which I'm not enjoying.

Thanks again...

Link to comment
Share on other sites

I don't know and can't seem to guess how you might be accessing this Forum structure. Maybe it's the Moderator thing getting in the way, but I don't see anything called a "thread list" on any view of any Forum sections/levels that I tried. Did you arrive at "the top" of the Forum or follow some link that dropped you into the midst of things? (Though I've not checked, I was assured that the www.spamcop.net Help pages would be re-written to only bring folks 'here' at the top of the Forum structure) Once within a Forum section, clicking on the Topic Title for instance brings the entire "discussion" to your screen.

Link to comment
Share on other sites

Thanks, I'll try it.  Now can someone tell me how to see entire threads or simply "go to the next message" on this board?  I can't seem to find a switch to do this here.  I do see the thread list on the bottom of the window, and can click one msg at a time, which I'm not enjoying.

21932[/snapback]

To see all of the most recent messages in this Forum, click "SpamCop Email System & Accounts" above. To see all of the Fora, click "SpamCop Discussion" above. "SpamCop Discussion" above is pretty useless from my POV, as it is just all the non-announcement Fora, and who doesn't want to see the announcements? :)
Link to comment
Share on other sites

I don't know and can't seem to guess how you might be accessing this Forum structure.

21933[/snapback]

I figured it out. There is a selection "Outline·Standard·[ Linear+]" that defaulted to "Outline," which is just the original and one reply with the thread tree: "Posts in this topic."

I switched it to "Linear +" and now see all the messages in the thread.

Thanks again for your patience.

Link to comment
Share on other sites

Timing is off ... was just going through some of the source code for this thing (working another issue) and saw that toggle that I'd totally forgotten about .. came back to make the suggestion .. see you found it ... Good work! <g>

Link to comment
Share on other sites

I just signed up for Spamcop.net and all seems to be working smoothly, except my first batch of messages were empty messages with no subject line.  Is there someway to immediately have them deleted or shoved to the held mail area before I see them?

21916[/snapback]

I believe if you activate SpamAssassin, it will take care of these automatically. My SpamAssassin level is set to 3, but it also worked when I had it at the default level (5).

It's in Options -> Spamcop Tools -> Select your email filtering blacklists.

Link to comment
Share on other sites

I believe if you activate SpamAssassin, it will take care of these automatically.  My SpamAssassin level is set to 3, but it also worked when I had it at the default level (5).

It's in Options -> Spamcop Tools -> Select your email filtering blacklists.

21965[/snapback]

I was at 5, and they were getting through. I tried the suggestion about filtering out the [at]-less addresses and that seems to be sending them into the hold box.

But interestingly I see some are there with message sizes like 100k, and they can't be opened to see what's inside them. They are not hot-linked to open. If I move them to my inbox just to see what's inside, they won't move because of the filter. I haven't bothered removing the filter and have been tossing them out.

I'll have more questions the more I play with this. For instance, deleting is a 2 step operation, delete and then empty trash. I can't seem to find a one step way of doing this.

Link to comment
Share on other sites

I was at 5, and they were getting through.  I tried the suggestion about filtering out the [at]-less addresses and that seems to be sending them into the hold box.

Overnight, I had 18 messages with no Subject redirected to my Held mail, 6 of which contained no body. I found that most were caught by the "bl.spamcop.net" so I wonder why so many of yours are getting through? I'm using a SA level of 5, which is pretty tolerant, but I've selected most of the blacklists in the options. Are you sure that you have the SpamCop Blacklist selected?

deleting is a 2 step operation, delete and then empty trash.  I can't seem to find a one step way of doing this.

I clean out my Held mail each morning using an IMAP-capable email client on my computer, instead of logging into the webmail interface. I don't use any webmail filters, however.

DT

Link to comment
Share on other sites

I was at 5, and they were getting through.  I tried the suggestion about filtering out the [at]-less addresses and that seems to be sending them into the hold box. 

<snip>

For instance, deleting is a 2 step operation, delete and then empty trash.  I can't seem to find a one step way of doing this.

21967[/snapback]

Well, I guess I was wrong about SpamAssassin. Or else our empty messages are different. All I'm using are bl.spamcop.net and SpamAssassin, and I never get empty messages in my Inbox. Next time I see one, I'll check why it was held.

As for deleting, it is always a 2-step process and I think that is a good idea. First time you delete a message by mistake, you will see why.

You have two options -- you can have your deleted messages sent to the Trash folder, or you can leave them in their original folder and "purge" them periodically (but you have to purge each folder individually).

These options are in Options -> Deleting and Moving Messages.

Link to comment
Share on other sites

Thanks for all your help. I've significantly cut down on my spam, but some of those empty, black messages are still appearing in my inbox. My SpamAssasin limit is 5. I filter msgs with no "[at]" out. Yet here is one of several with no "From," subject or content that slipped though. I have 3 "blacklists" selected: SpamCop, SPEWS level 1 and DSBL open relays.

Maybe someone can decipher the header for me and tell me how it slipped though:

Received: from slant.wprost.pl ([239.233.63.168])

by expedition.dora.com (Sun Java System Messaging Server 6.1 HotFix 0.05 (built Aug 28 2004)) with ESMTP id <0O9J00LN6[3

X-spam-Checker-Version: SpamAssassin 3.0.0 (2004-09-13) on blade5

X-spam-Level: *

X-spam-Status: hits=1.6 tests=FORGED_RCVD_HELO,MISSING_DATE,MISSING_SUBJECT

version=3.0.0

X-SpamCop-Checked: 192.168.1.101 63.151.139.116 81.251.141.3 239.233.63.168

Any ideas?

Thanks and happy new year...

Link to comment
Share on other sites

My SpamAssasin limit is 5...

Maybe someone can decipher the header for me and tell me how it slipped though:

Received: from slant.wprost.pl ([239.233.63.168])

by expedition.dora.com (Sun Java System Messaging Server 6.1 HotFix 0.05 (built Aug 28 2004)) with ESMTP id <0O9J00LN6[3

X-spam-Checker-Version: SpamAssassin 3.0.0 (2004-09-13) on blade5

X-spam-Level: *

X-spam-Status: hits=1.6 tests=FORGED_RCVD_HELO,MISSING_DATE,MISSING_SUBJECT

version=3.0.0

X-SpamCop-Checked: 192.168.1.101 63.151.139.116 81.251.141.3 239.233.63.168

22158[/snapback]

Notice the X-spam-Status: hits=1.6 above - that would only be held if you had your SpamAssassin limit set to 1 or 0 (not recommended).
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...