Jump to content

[Resolved] Allowed characters in email address


Recommended Posts

What characters are allowed in a spamcop.net/cesmail.net/cqmail.net email address?

I'm planning on getting a new account, and I'm thinking of adding a special character or two to make it less susceptible to dictionary attacks, if special characters are permitted.

Link to comment
Share on other sites

What characters are allowed in a spamcop.net/cesmail.net/cqmail.net email address?
RFC 2822 sets out the technically allowable characters - ref Wikipedia digest E-mail address but note
Notwithstanding the addresses permitted by these standards, some systems impose more restrictions on email addresses, both in email addresses created on the system and in email addresses to which messages can be sent.
I'm not sure you need worry about spam hitting a spamcop.net account - effective filtering and "very easy reporting" facilities are available, not only to keep the spam out of your inbox but also to feed the SC blocklist and so enhance its value for all users.
Link to comment
Share on other sites

What characters are allowed in a spamcop.net/cesmail.net/cqmail.net email address?

I'm planning on getting a new account, and I'm thinking of adding a special character or two to make it less susceptible to dictionary attacks, if special characters are permitted.

Taking the question to the next level .. if you manage to use an exciting and wonderful character 'here' ..... then the same question would have to asked for those folks that you would like to receive e-mail from ... can their e-mail servers handle/allow the same wild chracter?

Link to comment
Share on other sites

I know that alphanumeric characters are ok. Are there others that are considered completely reliable?
To paraphrase the answers - no. Well, I'll retract that - the period except in the first or last positions and the underscore and the dash *seem* to be universally accepted. Since they all *should* be accepted (Wikipedia - RFC 2822) but evidently aren't, all bets are off really.
Link to comment
Share on other sites

  • 2 weeks later...
To paraphrase the answers - no. Well, I'll retract that - the period except in the first or last positions and the underscore and the dash *seem* to be universally accepted. Since they all *should* be accepted (Wikipedia - RFC 2822) but evidently aren't, all bets are off really.

Using the SpamCop webmail interface I've been unable to send to

accounts with a username tagged using "+" as in

"fredfighter+usenet(atsign)spamcop.net". The webmail interface

'expands' the address to "fredfighter, usenet(atsign)spamcop.net".

More details can be read here:

http://groups.google.com/group/news.admin....91m8W&hl=en

starting with this article:

http://groups.google.com/group/news.admin....IrlbI7s34U2h_Jh

and continuing on for several more. It shouldn't be a hard bug to fix,

but I don't know how to contact anyone who could address the matter.

Link to comment
Share on other sites

Using the SpamCop webmail interface I've been unable to send to

accounts with a username tagged using "+" as in

"fredfighter+usenet(atsign)spamcop.net". The webmail interface

'expands' the address to "fredfighter, usenet(atsign)spamcop.net".

You are going to need to define your system a bit more. I just did a test and had no problems doing this, even forcing the "expand names" of the address.

I am using WinXP and IE7 with all patches as of last night.

http://www.spamcop.net/sc?id=z1225285203zd...d2e8a7b2e1e718z

The message was sent to underwood+test[at]spamcop.net with no problem.

It would really surprise me that webmail did not support this on outgoing since it supports it incoming. I have found many webform etc that do not support the +, however.

Link to comment
Share on other sites

You are going to need to define your system a bit more. I just did a test and had no problems doing this, even forcing the "expand names" of the address.

I am using WinXP and IE7 with all patches as of last night.

I'm using Firefox 5.0, under Windows 2000 Pro. I do NOT have

the problem using the Gmail webmail interface. I haven't tried

any others besides SpamCop and Gmail.

Link to comment
Share on other sites

I'm using Firefox 5.0, under Windows 2000 Pro. I do NOT have the problem using the Gmail webmail interface. I haven't tried any others besides SpamCop and Gmail.

Do you perhaps have an entry in your address book that has a space in it, causing the expansion to act in this way?
Link to comment
Share on other sites

  • 2 weeks later...

RFC 2822 sets out the technically allowable characters - ref Wikipedia digest E-mail address but note I'm not sure you need worry about spam hitting a spamcop.net account - effective filtering and "very easy reporting" facilities are available, not only to keep the spam out of your inbox but also to feed the SC blocklist and so enhance its value for all users.

Surely you jest.

I get up to 200 spams per day, most sent directly to my SpamCop account.

The blacklists and Spamassassin catch about 90% of those, though often

the filters 'stall' for anywhere from a couple of minutes to several hours.

By 'stall' I mean that the email is properly tagged, but the filters are not

automatically applied when I log in and also nothing happens when I

click on the inverted triangle icon that is supposed to actuate filtering.

Then sometime later, they work and those emails get filtered.

I don't know what would happen if I reconfigured to block, instead of

to tag, but since I don't want to block instead of tagging, that issue

is moot.

--

FF

Do you perhaps have an entry in your address book that has a space in it, causing the expansion to act in this way?

No.

Also the expansion happens that way regardless of whether I use the

address book or simply type the address in manually in the "Compose"

window. The problem is also present using IE6.x, there does not appear

to be a more recent IE update for W2kP.

I haven't tried replying to a "plussed" address. How about if send to

me at fredfighter[at]spamcop.net, from a plussed address, with "PLUSSED

ADDRESS TEST" in the subject line and I will try that.

--

FF

Link to comment
Share on other sites

Surely you jest.

I get up to 200 spams per day, most sent directly to my SpamCop account.

Then you have not handled that address in a very careful way. I have been using my spamcop account exlusively for over a year and get about 5-10 spam messages a day, maybe 1 or 2 of which are diirectly to the spamcop address. And I do absolutely no munging on my spamcop reporting.

The blacklists and Spamassassin catch about 90% of those, though often

the filters 'stall' for anywhere from a couple of minutes to several hours.

By 'stall' I mean that the email is properly tagged, but the filters are not

automatically applied when I log in and also nothing happens when I

click on the inverted triangle icon that is supposed to actuate filtering.

The blacklists and spamassassin are in no way connected to the "filters" or the inverted triangle icon. Those are both related to the local filter rules you need to create. Without knowing what you are doing with your filters, there is not much more help we can provide.

Then sometime later, they work and those emails get filtered.

I don't know what would happen if I reconfigured to block, instead of

to tag, but since I don't want to block instead of tagging, that issue

is moot.

Where do they get filtered?

If you have your account set to tag only, everything will end up in your inbox from the spamcop server filters. The message will simply have a: X-SpamCop-Disposition: line added to the headers.

Then when you log in, any personal filters you have setup in webmail (flters icon at the top) will run if that setting is checked or manually with the inverted triangle icon. Those rules need to match exactly in order to work.

It is also possible you have an email client configured for IMAP access that has filters configured that are moving messages around.

The following rule works for me when trying to count how many messages in my trash were held by a specific list.

Rule Name :      [b]Disposition[/b]
For an incoming message that matches: 
All of the following

     Self-Defined Header:   Contains [b]cbl.abuseat.org[/b]   
  [b]X-Spamcop-Disposition[/b]

and     Select a field

Do this: 
 Deliver to mailbox:  Held Mail

Mark message as: 
Important

 Stop checking if this rule matches?  (unchecked)

Link to comment
Share on other sites

Also the expansion happens that way regardless of whether I use the

address book or simply type the address in manually in the "Compose"

window. The problem is also present using IE6.x, there does not appear

to be a more recent IE update for W2kP.

I haven't tried replying to a "plussed" address. How about if send to

me at fredfighter[at]spamcop.net, from a plussed address, with "PLUSSED

ADDRESS TEST" in the subject line and I will try that.

--

FF

I see what problem you are having, but can not replicate it on any system I have access to (Win98, Win2K, WinXP, and Win2003 all with IE6)

To show what is coming across the line, I used the message source and have pasted it here for others to see:

To: "Steven P. Underwood" <underwood+forum[at]spamcop.net>
Cc: "underwood forum"[at]spamcop.net, underwood+forum[at]spamcop.net

This was a reply to a message I sent FF. He replied and tried to copy into the CC (looks like twice).

FF: Do you have some sort of application on your system that might be trying to fix typos for you? It looks like it worked fine when you simply replied, only when you entered the address yourself (copy/paste) did the problem happen. BTW, do you know how the 2 addresses showed up in the CC line?

Link to comment
Share on other sites

...To be safe, I settled on a 12-character alphanumeric username for my new account.
Thanks for the feedback Dave - I think you made a wise choice FWIW - mixed A-N seems to be the general recommendation but it was worth exploring the boundaries (things change).
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...