Jump to content

wikka help - nothing to do with SpamCop.net


Recommended Posts

The wikka folks still have yet to set up a support 'forum' ... replying via comments on a wiki page basically sucjs, especially when trying to work around formatting, code, etc. .... so to make things easier (on myself) am bringing this 'conversation' into this application, this spot ...


Specific dialog thus far;

Hi Guys, I updated to from ... the update screen went "OK" and everything checked out fine. When I went to my site all I got was "Page was generated in 0.0141 seconds" ... that is all, no info, no site, just that one single line.

How do I fix this?


Thank you for your time and help!

-- KeitH (2007-05-10 21:10:17)

Have you checked out this link?


I noticed that the hosting provider is inserting a frame, which might be causing some problems.

-- BrianKoontz (2007-05-10 22:36:12)

Thank you BrianKoontz... I looked into that and tried it and I still get a page with only the "page generated" time. I copied my backed-up wikka.php from and it gave me an "upgrade" screen on loading the site. I switched it back to the original wikka.php and I am now back to square one again. The site is hosted on my uncles server and he doesn't include frames (at least from what he has told me). Its nothing fancy. If I had a guess it might be some security option he has enabled possibly? He has the latest and greatest PHP and MySQL versions running and everything checked out on the upgrade screens. Any and all suggestions are very welcome at this point. Many thanks for your time and help!

-- KeitH (2007-05-11 01:31:58)

If you look at the HTML source of the blank page, you'll see an embedded frame. That was the frame I was talking about.

I'll do some more testing with to see if I can replicate your problem.

-- BrianKoontz (2007-05-11 10:01:58)

Hmm, indeed ... thank you BrianKoontz. I also contacted my uncle about it, Im not very good when it comes to PHP and a second pair of eyes always helps. Thank you for looking into this. :)

-- KeitH (2007-05-11 11:29:51)

KiethH ... what is currently seen;

05/11/07 21:14:27 Browsing http://www.freeed.org/

Fetching http://www.freeed.org/ ...

GET / HTTP/1.1

Host: www.freeed.org

Connection: close

HTTP/1.1 302 Moved Temporarily

Content-Length: 0

However, this all there is ... there is no location offered for the 302 redirect .....

One possible issue is the configuration file .. the next being the .htaccess file ... one of them currently "pointing" to a non-existent location .... that is unless you have something else going on at the moment ....

-- WazoO (2007-05-11 23:07:03)

'base_url' => 'http://metafocus.net/~freeed/wikka.php?wakka=',

Could the "~" be causing the snag? .. .htaccess didn't seem to point to anything. Should it? Here is what it looks like under all the pron "bad referral" stuff:

<IfModule mod_rewrite.c>

# turn on rewrite engine

RewriteEngine on

# if request is a directory, make sure it ends with a slash

RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^(.*/[^/]+)$ $1/

# if not rewritten before, turn request into a query for wikka.php

RewriteCond %{QUERY_STRING} !wakka=

RewriteRule ^(.*)$ wikka.php?wakka=$1 [QSA,L]


-- KeitH (2007-05-11 23:35:30)

Quick glance .. the 'base_url' doesn't seem right ... you've actually got more of a 'command' in there .... I don't know the structure of your system, but ....

The '~' character is fairly standard for an ISP hosting 'virtual' domains .. typically the 'freeed' part is 'your' account's web space area ...

If you nstalled this wikka in the 'root' folder and there is no other .PHP, .HTML, etc. file sitting there, then I would suggest that the 'base_url' definition should read;

'base_url' => 'http://metafocus.net/~freeed/',

What I would have suggested way back when would be that you'd have installed this application into its own folder/directory, which then also would have then wanted to see something more like;

'base_url' => 'http://metafocus.net/~freeed/wikka/',

hope this helps ...

-- WazoO (2007-05-12 23:20:21)

Oh, that would make since... I wonder if the updater (since I ran it from freeed.org and NOT metafocus.net/~freed) if the updater put in that tid-bit of code? Hmm... I'll try it tonight when I get home. I think that might be it... I wonder if my domain name masking/forwarding from Godaddy.com is causing the issue?... would it be advisable to either take out that tid-bit of info from the config file, OR just delete it all (except the config file) and try the updater again from the "proper location"?

Thank you for your help on this WazoO! I would have never of looked at this. :)

-- KeitH (2007-05-14 10:52:32)

Hi guys, I tried re-upgrading it again tonight (after the config file change failed to work). I ran the update from my host directly this time. Sadly ended up with the same results. Though this time I took screen shots to show whats going on during this. Any obvious errors? ... I notice the updater is still putting in that "wikka.php?wakka=" to the config file:





Many thanks once again.

-- KeitH (2007-05-15 00:02:39)

Answer to this is simply too complicated for this Comment type dialog. I am actually going to toss up data, questions, etc. in an actual support Forum ...

please see http://forum.spamcop.net/forums/index.php?showtopic=8287

-- WazoO (2007-05-15 05:43:01)

Link to comment
Share on other sites

OK, from the top .... one of the things I'm really curious about is exactly what files are located in the 'root' folder (and a couple of other folders, as far as that goes) ....

Domain ID:D104856752-LROR

Domain Name:FREEED.ORG

Created On:08-Sep-2004 05:35:22 UTC

Last Updated On:10-Jun-2006 17:43:55 UTC

Expiration Date:08-Sep-2009 05:35:22 UTC

Sponsoring Registrar:Go Daddy Software, Inc. (R91-LROR)





OK DNS is there ...

Fetching http://www.freeed.org/ ...
GET / HTTP/1.1
Host: www.freeed.org
Connection: close
HTTP/1.1 302 Moved Temporarily
Content-Length: 0
Location: /?7442ea28

However, still nothing but the 302 (Moved) message ...

Fetching http://www.freeed.org/wikka.php ...
GET /wikka.php HTTP/1.1
Host: www.freeed.org
Connection: close
HTTP/1.1 302 Moved Temporarily
Content-Length: 0
Location: /wikka.php?7442ea28

Again, nothing but the 302 (Moved) message ....

Implication is that the wikka.php is not in the 'root' folder .... but that doesn't mean much, as the .htaccess file probably redirects to somewhere else ...

Fetching http://metafocus.net/~freeed/wikka.php ...
GET /~freeed/wikka.php HTTP/1.1
Host: metafocus.net
Connection: close
HTTP/1.1 302 Found
Date: Tue, 15 May 2007 09:56:10 GMT
Server: Apache/1.3.37 (Unix)
Set-Cookie: 96522b217a86eca82f6d72ef88c4c7f4=29a00u2l0fr7f80i5js588n2k2; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Location: http://metafocus.net/~freeed/wikka.php?wakka=HomePage
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html

Got some HTML header data there, but .... still the 302 (Moved) error message .. although, this time there is a 'new' location listed .... so let's go there ....

Fetching http://metafocus.net/~freeed/wikka.php?wakka=HomePage ...
GET /~freeed/wikka.php?wakka=HomePage HTTP/1.1
Host: metafocus.net
Connection: close
HTTP/1.1 200 OK
Date: Tue, 15 May 2007 09:57:03 GMT
Server: Apache/1.3.37 (Unix)
Set-Cookie: 96522b217a86eca82f6d72ef88c4c7f4=8grn8b4hiesrpav41800pf3rf1; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-cache
Pragma: no-cache
ETag: 4ece45e5248ba5bda55bc88e59ad05b8
Content-Length: 82
Connection: close
Content-Type: text/html

&lt;div class="smallprint"&gt;Page was generated in 0.0148 seconds&lt;/div&gt;

Well, there's the page you 'see'

You've already been pointed to the page about possible issues with "mod_rewrite" not being available, so we're supposed to ignore that ....

One could guess that it may be becaise the "HomePage" doesn't yet exist, but .... what you should see there is a nice fully-formed page with the coment "This page doesn't exist yet. Maybe you want to create it?"

Trace www.freeed.org ( ...

* RTT: 71ms TTL:170 (ip-64-202-160-153.secureserver.net probable bogus rDNS: No DNS) RTT: 69ms TTL:170 (pwfwd-v01.prod.mesa1.secureserver.net ok)

Trace metafocus.net ( ... RTT: 67ms TTL:170 (sb0.impulse.net fraudulent rDNS) RTT: 106ms TTL: 54 (sb0-cf9a64a2.dsl.impulse.net ok)

Trace metafocus.net/~freeed/ failed, no such host

Basically, at this point, I can only say that I can't see what's actually going on, as I can't see what the file structure looks like ... even worse, there may actually be some server settings that are part of the issue. For me to dig any further, I'd have to request FTP data so I could actually login and take a real look at what's where .... please don't post that data publically ....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...