Jump to content

[Resolved] Messages sent using SC webmail contain invalid Message-IDs


Recommended Posts

Not sure how long this has been going on, but when a message my wife sent to herself wound up in her Held folder, I analyzed the headers and found that the following Spamassassin rule had fired:

MSGID_MULTIPLE_AT

So, looking at the Message-ID generated by the SpamCop webmail system, I saw multiple [at] symbols, which apparently isn't allowed by RFC 2822 sec 3.6.4. Here's a link to the SA Wiki article on this:

http://wiki.apache.org/spamassassin/Rules/MSGID_MULTIPLE_AT

and here's a sample Message-ID from a message I sent to myself:

Message-ID: <20080602050631.9j8hdrb6hws84044-gbccvat[at]fcnzpbc.arg[at]webmail.spamcop.net>

(The real one had true "at" symbols, but this forum software has been tweaked to replace them with "[at]") The problematic Message-ID is adding a score of 1.2 to messages we send, which is significant, and when combined with other possible attributes, might cause our messages to be dumped or trapped. This needs a "JT fix" ASAP, IMO, so I'll also email Support.

DT

Edited by DavidT
Link to comment
Share on other sites

...found that the following Spamassassin rule had fired:

MSGID_MULTIPLE_AT

So, looking at the Message-ID generated by the SpamCop webmail system, I saw multiple [at] symbols, which apparently isn't allowed by RFC 2822 sec 3.6.4.

Yes, certainly seem to be the case. Thanks for identifying this for us :)

Andrew

Link to comment
Share on other sites

I disagree. 2822 doesn't so define MID. Elaborated in news spamcop.mail including links to RFC.

I would get rid of the SA rule if it causes more harm than good. It isn't based on 'fact'.

However....right or wrong, the SA rule may be in use at numerous sites "out there" and it would therefore be in *our* best interest if JT jiggered the MID so that it didn't fire the rule. I'm not supporting the validity of the SA rule, but rather reporting on a negative consequence for SC email customers.

DT

Link to comment
Share on other sites

Good news on this: Trevor responded quickly, agreed that this was a bug, and he fixed it immediately.

<snip>

...Nicely done, DT (and Trevor)! Based on this good news, I shall mark this thread as "Resolved."
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...