Jump to content
Sign in to follow this  
Brenda

Will mailhost work for my configuration?

Recommended Posts

I'm a little confused about the mailhost system after having read through the info several times. Part of my confusion stems from trying to configure my mailhosts a few times, encountering errors and deciding that this may not work for me.

My first question has to do with DNS: I use zoneedit for DNS. My primary MX is a host in my domain and my backup MX is a host at zoneedit. When I clicked the "Add first hosts" link, entered my primary email address and proceeded to step 2, spamcop correctly offerred to send test emails for both MX's.

I received two test emails. I can successfully complete processing for the one sent via my primary MX (dmz.theotherbell.com). But when I try to complete processing for the one sent via my backup, it fails with the following error:

The email sample you submitted for <email address here>

appears to traverse more than one domain.

Please ensure that you configure each mailhost individually and in order.

I get this error regardless of the order in which I process the two emails.

My second question has to do with email accounts: I use qmail as my mail server and make wide-spread use of qmail's dash-extensions. That is, I can create new email addresses on-the-fly and these one-off addresses can be quickly disabled without impacting my real (permanent) email address. All of these addresses are in the same domain. I believe I saw something that said I only need to configure mailhosts once for one address in a domain... but I have not been able to relocate that reference.

I would like to confirm that I'm understanding this correctly... i.e., I only need to configure a mailhost using a single email address from each domain -- that config would cover the host that handles all email for all recipients in the domain. Is that correct?

Edited by Brenda

Share this post


Link to post
Share on other sites

Your actions and assumptions appear to be correct. Please forward the email that "appears to traverse more than one domain" and the correctly processed one to deputies<at>spamcop.net and reference mailhosts in the subject. Thanks!

Share this post


Link to post
Share on other sites

Thanks for your response. The details regarding the mail that generated the error are on their way.

However, I just realized I've done something I never ever do. I was so careful trying to post accurate and complete information, I neglected to obscure my email address in my original post. Is there any way I can modify that post or have one of the moderators/admins do it for me?

I can't believe I did that (very red-faced and embarrassed :)

Share this post


Link to post
Share on other sites

It looks like you found the "EDIT" button. I'm sorry I didn't notice the address earlier.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×