Jump to content

parse page failing to load?


Recommended Posts

I've been using SpamCop for years, but either something has gone wrong or the last spam I received is stalling it somehow. My first thought was reload, but it stopped at the exact same point. So I went back to the reporting box and tried pasting in the spam again, thinking maybe it would go through this time. Neither of my ideas made any difference. It's been so long since I've ran into any issue like this, I'm not sure how to troubleshoot beyond this, so anything I haven't already tried would be appreciated.

It always stops at the same point:


Parsing header:
host 2a01:111:e400:fc11:0:0:0:42 (getting name) no name
host 2603:10b6:300:c2:0:0:0:27 (getting name) no name

Here's one of the tracking URLs: https://www.spamcop.net/sc?id=z6702233527zbcd30846d6b3149bd78570af38518361z


Link to comment
Share on other sites

I think I found it.

Received: from beactive.it ( by xHRZDMoSZQtTgIAffdczjrWWwatOgPNzFmircaawrvITFdBVQxutRnEWUepKPlOSwGJOqJfGFYyixSZjQnQWiQxqdPmvWeFgxrYmbRuJHWQgniKgFaMzPNMarqJOpuDIqmBFzSYld.mail.protection.outlook.com id pDAvY7enim86 for <x>; Tue, 09 Feb 2021 01:00:58 +0100 (envelope-from <return@nvse2fv2dfx.work>

The hostname appears to be too long on the above line.

C:\>dig any xHRZDMoSZQtTgIAffdczjrWWwatOgPNzFmircaawrvITFdBVQxutRnEWUepKPlOSwGJOqJfGFYyixSZjQnQWiQxqdPmvWeFgxrYmbRuJHWQgniKgFaMzPNMarqJOpuDIqmBFzSYld.mail.protection.outlook.com
dig: 'xHRZDMoSZQtTgIAffdczjrWWwatOgPNzFmircaawrvITFdBVQxutRnEWUepKPlOSwGJOqJfGFYyixSZjQnQWiQxqdPmvWeFgxrYmbRuJHWQgniKgFaMzPNMarqJOpuDIqmBFzSYld.mail.protection.outlook.com' is not a legal name (label too long)



Link to comment
Share on other sites

Thanks for pointing me in the right direction. I wasn't sure whether to look at the message, or maybe there was an issue with my computer or SpamCop's parser.

Although there are no double periods in the whole email, that got me to looking at the message. I tired removing things that looked strange. The one that seemed to be the problem was a hostname that began with "xHRZDMoSZQtTgIAffdczjrWWwatOgPNzFmircaawrvITFdBVQxutRnEWUepKPlOSwGJOqJfGFYyixSZjQnQWiQxqdPmvWeFgxrYmbRuJHWQgniKgFaMzPNMarqJOpuDIqmBFzSYld" as it started working when I changed that portion to "removed."

If I recall correctly (it's been years), we shouldn't report things with material changes, so I cancelled. But at least we know what was tripping up the parser.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...