Jump to content

Whats up with CastleCops?


jongrose
 Share

Recommended Posts

Seems ok for me Jon. I should think there would be mention at de.castlecops.com if/when things get really bad over an extended period for castlecops.com. There was last year, in the incident that forced them to move servers.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, all!

I know that this thread is fairly old by now, but, in case anyone is still interested, CastleCops seems to be responding well at the moment, and has been for about the last 36-48 hours.

I'm keeping my fingers crossed, hoping that it will stay that way! :D

Up until last Friday, whatever link I clicked on, I'd get several page load errors, network timeouts, etc., but if the Firefox status bar ever got past "Connecting..." to "Waiting...", I might still have time to go out, have a full English Breakfast, do my morning shopping, come back home and eat lunch, by which time the desired page just might finally have loaded! :blink:

However, since around late Friday evening or early Saturday morning (in Sydney, Australia), the site's response time seems to have improved almost to pre-2007 DDoS levels! :D

Several CastleCops admins/regulars have denied on their forums that there has been any DDoS attack in the last few months, stating that the slow response problem lies with hardware and/or software. (I know that they need new server hardware, but then, why have the response times improved now? The progress scale about their drive for donations for the new hardware they need has not changed for several weeks, and they seem to be still about $USD11,000 short, which suggests to me that the new hardware has not yet been acquired).

Anyway, it's working well, now, which is great for me, because I've recently been getting hundreds of spams with malware links, which, of course I've been religiously reporting to MIRT. ;)

Just my 2 cents' worth.

Link to comment
Share on other sites

... in case anyone is still interested, CastleCops seems to be responding well at the moment, and has been for about the last 36-48 hours.

...

Anyway, it's working well, now, which is great for me, because I've recently been getting hundreds of spams with malware links, which, of course I've been religiously reporting to MIRT. ;)

Thanks Chris, yep, people will be interested. And say a few 'Ave Maria's on my behalf while you're at it. :D

Steve

Link to comment
Share on other sites

Yeah, that's pretty much the same problem I've been having. Some days it's extremely slow to the point of being totally inaccessible, but other days it seems to work okay. I assumed it was DoS attacks against them, but I know they are using Prolexic which is supposed to be DoS proof, so I couldn't understand what the problem was.

Anyway, thanks for the insight.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...