Jump to content

Installing GraemeL's "S.A.L.T"


Recommended Posts

This is a continuation from some OT stuff I started here:


So...Graeme, it seems that my primary sticking point is the lack of "Authen::SASL" which I tried installing using cpan like this:

i Authen::SASL

and my box responded like this:

CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Tue, 02 Oct 2007 05:36:43 GMT
Strange distribution name [Authen::SASL]
Module id = Authen::SASL
	DESCRIPTION  SASL authentication framework
	CPAN_USERID  GBARR (Graham Barr <gbarr[at]pobox.com>)
	CPAN_FILE	G/GB/GBARR/Authen-SASL-2.10.tar.gz
	DSLI_STATUS  RmpO (released,mailing-list,perl,object-oriented)
	INST_FILE	(not installed)

I tried this, because I was having problems during a manual install of the SMTP_auth Perl module. When I ran "perl Makefile.PL" I got this:

# perl Makefile.PL
Checking if your kit is complete...
Looks good
Warning: prerequisite Authen::SASL 2.03 not found.
Writing Makefile for Net::SMTP_auth

and then when trying to "make test" I got this:

cp SMTP_auth.pm blib/lib/Net/SMTP_auth.pm
PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
Can't locate Authen/SASL.pm in [at]INC ([at]INC contains: blib/lib/5.8.3/i386-linux-thread-multi blib/lib/5.8.3 blib/lib/i386-linux-thread-multi blib/lib/5.8.2 blib/lib/5.8.1 blib/lib/5.8.0 blib/lib blib/arch/5.8.3/i386-linux-thread-multi blib/arch/5.8.3 blib/arch/i386-linux-thread-multi blib/arch/5.8.2 blib/arch/5.8.1 blib/arch/5.8.0 blib/arch /usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3 /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at blib/lib/Net/SMTP_auth.pm line 27.
BEGIN failed--compilation aborted at blib/lib/Net/SMTP_auth.pm line 27.
Compilation failed in require at test.pl line 11.
BEGIN failed--compilation aborted at test.pl line 11.
not ok 1
make: *** [test_dynamic] Error 2

So...how to proceed?



Link to comment
Share on other sites

So...how to proceed?

My fault. The i command only looks for modules matching your text and doesn't actually try to install them. Run cpan and then try "install Authen::SASL". Once you've done that, there hopefully shouldn't be any more dependencies and the make on NET::SMTP_auth should be able to complete.

Link to comment
Share on other sites

Run cpan and then try "install Authen::SASL".

Just tried that, but...

CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Tue, 02 Oct 2007 05:36:43 GMT
Running install for module Authen::SASL
Running make for G/GB/GBARR/Authen-SASL-2.10.tar.gz
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
CPAN: Digest::MD5 loaded ok
Fetching with LWP:
CPAN: Compress::Zlib loaded ok
Checksum for /root/.cpan/sources/authors/id/G/GB/GBARR/Authen-SASL-2.10.tar.gz ok
Scanning cache /root/.cpan/build for sizes
Use of uninitialized value in chdir at /usr/lib/perl5/5.8.3/CPAN.pm line 929.
Use of chdir('') or chdir(undef) as chdir() is deprecated at /usr/lib/perl5/5.8.3/CPAN.pm line 929.
Uncompressed /root/.cpan/sources/authors/id/G/GB/GBARR/Authen-SASL-2.10.tar.gz successfully
Using Tar:/bin/tar xvf /root/.cpan/sources/authors/id/G/GB/GBARR/Authen-SASL-2.10.tar:
Couldn't untar /root/.cpan/sources/authors/id/G/GB/GBARR/Authen-SASL-2.10.tar

it failed. Tried going in, extracting the files and running the installation manually, and it had more problems, including some memory allocation issues....so...I give up for now. Thanks, anyway, Graeme.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...