Jump to content

[Resolved] Forum feature request


lcusdtech
 Share

Recommended Posts

Actually, purchasing our admin a keyboard with engraved keys may make the biggest difference ;)

I thought there was history on this issue being that JT was going to purchase that option once a forum software was chosen, bit since "priority" actions are taking ~10 days right now, this is at the bottom of the todo list.

Link to comment
Share on other sites

Lots of ripples in that pond. Once upon a time, IPB was working on their own spell-checker. Once upon a time, the spell-check function was an incentive to buy the full release. Once upon a time, it was going to be part of the 2. release. Well, buying a perpetual locense didn't bring it into reality. Release 2.1.5 is due out soon and it isn't going to be found there. The internally developed spell-check thing has been dropped. Versinon 2.1.x does have links to a third-party product, iespell .. such that if one is using IE with java scri_pt/ActiveX allowed, then one has access to the iespell routine via a link that shows up in the editor. Way back when, JT didn't wish to install PhpSpellChecker due to the modifications involved. From some previous conversations, he's also not aware of all the modification that I've been doing to it, but that's another story for another time.

I downloaded PhpSpellCheckerV2_1.zip a number of months back, PhpSpellCheckerV2_2.zip a day or two after it was posted (noting after that download that the hype on it was that it was upgraded to work with version 2.1.x of the Forum application. Just now looking at the install files, I do see that in theory, the 2.0.x version are still supported in this last release .. just haven't seen the "successfully installed" remarks to back that up)

So starting with JT saying "no" way back when ... fast forwarding to me saying a few words and doing some stuff anyway, this one has been floating at the edges of my attention for a while ... Let me start with the "easy" installation step, stated as "This will install the dictionary to your mysql database. This process can take some time to complete." That's one of the caveats that's had me holding off on starting to try to install this one. The last Forum modification in reality shouldn't have taken more than 10 minutes to install .. but it took me most of a day, having to dance around file ownership, folder permissions, and MySQL access issues. Due to the same issues existing today, I can't do an install as per the instructions ... most of this I have to do by hand, one command at a time .... which based on the warning "this may take some time" ... it's always been pushed off until I figured I had "that much" time to work through it.

Trying to populate the KnowledgeBase/FAQ thing (but trying to get the Official FAQ data fixed first) has been one of the time-consuming issues of late .... trying to hack another of Dean's mods to do something different has been another focus point .. and then there's that real-life issue that keeps popping up <g> ... just back home from changing locks / installing deadbots on a brother's house, after dropping off two repaired systems at their respective owners' homes, with the attendant reconnecting everything amd a bit of hands-on .. there was the nephew's wife's car yesterday evening, brought into the picture after walking the nephew through replacing, aligning, and tensioning a chainsaw blade on the chainsaw he was borrowing from 'grandpa' ... but when 'grandpa' was asked about the car problems, 'grandpa' complained about all the fancy new stuff, fuel injection, computer brains, electroinc sensors .. sent him back up the street to talk to me about that problem <g> (going with the sensor after the catalytic convertor gone nuts trying to 'adjust' for the hole in the catalytic convertor is what had the "check engine" light turned on .. the exhaust note being the tip-off and that everything else I checked was good .. then had to show him where the sparkplugs were hiding <g>) ... another neighbor hit me up where his shovel was at ... advised that it was right next to the wire brush I was going to use to clean it with, which was right next to the can of WD-40 I was gong to spray it with after I cleaned it .. but I haven't been out back since I buried my dog out there ... just one of those things ... then pointed out that while I had the shovel and pick-axe, it might be a good time to dig down around the foundation and fix the source of my basement leak, but .... all too easy to talk myself out of starting that project ....

All that said, let me dig a bit deeper on whether I should play with version 2.1 or 2.2 of this app, see if I can figure out a sequence of installing it under the constraints I have ... and admitting that this will be 'after a while' .. not comfortable jumping into something like this when I'm feeling this tired .... was up at 0300 yesterday, it's now after 0100 .... don't want to spend too much time fixing my 'oops!'

Link to comment
Share on other sites

Wazoo... This is VERY err... frustrating for me because I refuse to use IEeeeeee whenever possible. I'm seeing two windows to compose in and if I compose in the LEFT window, I get an error that I must enter a post. I'm concerned that if I enter my post ONLY in the right window, it won't work correctly. Is there some way to make this work with Mozilla or to disable spell chucking on a per-user basis so we don't have this problem with two compose windows?

Link to comment
Share on other sites

Wazoo... This is VERY err... frustrating for me because I refuse to use IEeeeeee whenever possible. I'm seeing two windows to compose in and if I compose in the LEFT window, I get an error that I must enter a post. I'm concerned that if I enter my post ONLY in the right window, it won't work correctly. Is there some way to make this work with Mozilla or to disable spell chucking on a per-user basis so we don't have this problem with two compose windows?

35320[/snapback]

I've barely got the code / file changes inserted, already see oddities in that some "Comment" lines are leaking through ... give me at least a few minutes to check things out mysalf (going back to that I don't have a 'test' board to work out these issues first )

and I see that my first reply dropped all my text ...??? typing in the right-hand window this time ..????

Link to comment
Share on other sites

Wazoo... This is VERY err... frustrating for me because I refuse to use IEeeeeee whenever possible. I'm seeing two windows to compose in and if I compose in the LEFT window, I get an error that I must enter a post. I'm concerned that if I enter my post ONLY in the right window, it won't work correctly. Is there some way to make this work with Mozilla or to disable spell chucking on a per-user basis so we don't have this problem with two compose windows?

35320[/snapback]

There is the same issue WITH IE as I am seeing the same thing. And I see Wazoo having the same issue as I am. Must post into the right hand window.
Link to comment
Share on other sites

Back to a single window .... leaking Comment lines fixed ...

35327[/snapback]

now, does it actually work?

Dang, it seems to from here anyway (under IE right now)

FireFox 1.0.7 .... appearances and actions show it working from that browser also.

Link to comment
Share on other sites

This message will check the spelling of wrok, which wasn't corrected in the preview. :)

35331[/snapback]

I did an Edit, hit the button, got the pop-up screen, which showed;

Scanned 14 words. Found 1 words to be corrected.

and "wrok" was in red with suggested replacement words ....

Spell checking "this" post ... it in fact ignored the quoted section, but did latch onto my quoted word, offering up suggestions, though noting that "work" wasn't one of them ....

How it works .. well, java scri_pt needs to be running to allow that app to fly, it does 'arrive' on-screen as a pop-up, so there could be an issue there?

After hittig the "Spall Check button" ... the pop-up will contain the text entered into the posting window, the first word found will be in red ... options available to the right of that, select a word from the (possible) list, hit 'change' ... then it jumps to the next 'bad' word ....

Will assume that the 9k+ word file doesn't include a lot of the 'normal text here. One of the options is to 'add' a word, and I believe that somewhere in the past when first reading up on this app, 'your' added words get added to a cookie .. not checked for that truth thus far, but .... perhaps another Topic to be started for 'suggested' words to be added ...??? first things first though <g>

Added thus far; (started with the Glossary)

Admin

AOL

AUP

autoresponder

Blackhole

Blowback

DHCP

DNS

DNSbl

DSL

FAQ

FireFox

Google

HotMail

HTML

HyperText

IronPort

ISP

java scri_pt

LAN

MailHost

MSN

multipart

Phish

Phishing

rDNS

RFC

SCBL

SMTP

spam

SpamCop

spammer

spamtrap

spyware

TCP

URL

website

whitelist

WHOIS

Wiki

Yahoo

Link to comment
Share on other sites

It worked in IE, putting a "Spell Check" Button below the big "Enter your Post" text box. However, once my third Spell Check was complete, the Microsoft Visual C++ Runtime Library barfed the following:

Runtime Error!

Program: C:\Program Files\Internet Explorer\IEXPLORE.EXE

R6025

- pure virtual function call

[OK]

Link to comment
Share on other sites

please see http://forum.spamcop.net/forums/index.php?showtopic=5282

It worked in IE, putting a "Spell Check" Button below the big "Enter your Post" text box.  However, once my third Spell Check was complete, the Microsoft Visual C++ Runtime Library barfed the following:

35340[/snapback]

Hey, I'm still playing also, but ... I ran the Glossary post through the thing which was quite a work-out, I thought .... actually made over a dozen 'corrections' .. a couple that I skipped, some words I hesitated on adding ... but all functions I tried there worked ..

Link to comment
Share on other sites

That killed IE. :(

35342[/snapback]

What killed IE?

Ahh, but does it work?  Yes, it does, but I'd like to request the addition of scroll bars and/or maximize capability on the popup window.

35344[/snapback]

Again, it's a bit of java scri_pt .. the window size is defined, but that also feeds into the screen size/resolution issue asked about in a poll that's been barely touched .... scroll bar issue I'm not quite understanding .. I had both vertical and horizontal scroll bars while doing the Glossary .. used them both ..????

Link to comment
Share on other sites

What killed IE?

35346[/snapback]

Clicking the OK button after Microsoft Visual C++ Runtime Library barfed killed IE
Again, it's a bit of java scri_pt .. the window size is defined, but that also feeds into the screen size/resolution issue asked about in a poll that's been barely touched ....  scroll bar issue I'm not quite understanding .. I had both vertical and horizontal scroll bars while doing the Glossary .. used them both ..????

35346[/snapback]

Yes, there are scrollbars for the text being spellchecked (in the left panel), but not for the overall window. The right panel is overflowing due to Firefox's "Minimum font size". Edited by Jeff G.
Link to comment
Share on other sites

Thinking back to the bit on the text on the status graphic ... my default install shows "None" for Minimum Font size ... all versions of FireFox I've checked here ... I believe you said you had yours set to 18 ????

35350[/snapback]

Yes, it is at present, to compensate for a laptop with a bum backlight that I can't afford to replace right now. Scrollbars usually let me compensate for the larger font size, but not in this case.
Link to comment
Share on other sites

3 screenshots requested .... post with spellcheck window, PM post with spellcheck window, and a Quick-Reply with a spellcheck window ... those screens are a different size, as are the spellcheck window dimensions ... need the problem area stuck somewhere that I can use to guage some possibilities ...

OK, I lied ... the java scri_pt only defines the text entry box .. the rest of the 'form' is tapping into some Forum .CSS code ... so I'd have to generate some new class work definitions, whack the code some more, and see what the results would end up doing to any other things .... wondering now if the dimensions have to be changed or if a simple 'overflow' setting would solve your issue .... naw, it'd have to be the size thing, as it's your browser that's making the changes ....

Let me repeat, there isn't that overwhelming listing of folks that were jumping up and down with their install results .... I followed up the "demo site" .. not a lot of help there as they are only showing the thing under 2.1.x which s a whole different setup ....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...